Virtual desktop switch right/left doesn't work with certain layer modifiers

x64 Replacement/Alternative to Microsoft's IntelliMouse application.
Forum rules
Please read the forum rules before posting for the first time.
The more information you can provide, the quicker and more accurately someone can help.
NOTE: To reduce spam, new users can not post links or images until they have at least 4 posts.
Post Reply
New User
Posts: 5
Joined: Tue Sep 08, 2015 6:49 am

Virtual desktop switch right/left doesn't work with certain layer modifiers

Post by aepaep » Mon Nov 26, 2018 5:59 am

XMBC Version: 2.17
Windows Version: 10 x64 version 1803 build 17134.407
Mouse Information (brand/model): Corsair M65 Pro
Computer Information: Home grown, ASUS MB, i7 CPU, 32 GB RAM
Did the problem occur after an upgrade of XMBC or Windows?: No
How long have you used XMBC?: Years
What language and keyboard layout do you use in Windows?: US English

Clear description of the problem: In the past I used XMBC to map my left/right tilt buttons to move virtual desktop left and right. I am now using this new mouse (various reasons for that, including the nice ability to change DPI to alter cursor speed when I edit photos and such--and yes, I know XMBC can control cursor speed as well) but sadly it doesn't have a tilt wheel. So, I am using a different layer to map my virtual desktop switchers. I would rather avoid the keyboard, but haven't figured out a good way otherwise with this one. I have it working with the ctrl key alone (layer modifier) switching to layer 2 where I remap buttons 4 and 5. That will probably do me just fine, but I also experimented with using the Windows key as a modifier (kind of made sense to me) or the combinations shift-ctl or shift-alt.

The problem with the Windows key is that even when I use it to switch layers to switch virtual desktops, it still sends the actual Windows key to the OS, so after I switch it brings up the start menu. Maybe nothing you can do to fix that (and maybe not a big enough deal to try unless it is easy).

The problem with the 2-modifier keys is they don't work at all. In XMBC settings I can see the profile switch (as well as the notification balloon if I have that enabled) as well as the button 4/5 press, but it doesn't switch desktops. I do have the Corsair iCUE software installed that has a lot of configuration options (but not what SMBC has from what I can find). I tried stopping it and that didn't help. I also noticed there is a Windows service simply called "Corsair." The description for that services is ever so helpful--it just says "Corsair service." I'd like to punch developers that do that.... Anyway, I stopped that service as well and it did not correct the problem. I did not try restarting with the service disabled, and I haven't tried uninstalling the Corsair software completely.

I also just noticed one other thing--if I set the middle button to "Task View" on my layer 2 with only the ctrl key layer modifier it doesn't work either (shows being triggered in XMBC but does nothing). I already have that function on the middle button on layer 1, and it does work when I don't use the ctrl key to switch layers. I also tried setting the middle button on layer 2 to "Same as layer 1" but that didn't work either. If I select layer 2 from the task bar icon then the layer 2 setting for Task View on the middle button works properly.

I wanted you to at least be aware of these behaviors. If they aren't exhibited on your system than it may be whatever Corsair is doing. Given what I found about the Task View option I mentioned above, though, I am thinking it isn't the Corsair software, since it works fine unless I use the ctrl key to switch to layer 2. I should be OK just using the ctrl key as a modifier (in fact, the simpler the better) as long as it doesn't interfere with something else. It is used as a modifier in a lot of software (say Photoshop, which I use), so I would not be able to use that layer for modifying say, button presses. I might be able to just add another layer with a different modifier though.

Sorry this got so long, but wanted to make sure I gave as complete information as I could! I did search the forum first but didn't find anything related.

User avatar
Site Admin
Posts: 6000
Joined: Sun Apr 06, 2003 11:12 pm

Re: Virtual desktop switch right/left doesn't work with certain layer modifiers

Post by phil » Sat Dec 01, 2018 5:30 pm


The problem with modifier keys is that the key being pressed actual can effect what goes on.
For example, if you used CTRL as a modifier key, then CTRL is pressed, so say you wanted to simulate the key "C" on a button, that would cause CTRL+C to be pressed - and hence the copy command would activate.

XMBC can not block these keys - because that would be even worse, if for example the window key would never work, just switch layers - not good (esp. for ctrl/shift/alt). This has been covered here several times in the past and its not something I can do anything about. the only real option if to choose a key that does not interfere with the intended action (which is not always easy as different software can behave differently to various keys being pressed).

I'm afraid there is not really anything I can do about that!
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-9600k, Asus Z390-ROG, 16GB DDR4,
nVidia GeForce GTX 970, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

New User
Posts: 5
Joined: Tue Sep 08, 2015 6:49 am

Re: Virtual desktop switch right/left doesn't work with certain layer modifiers

Post by aepaep » Thu Dec 06, 2018 1:37 pm

Ah, that makes sense--interesting to know. Your response is much appreciated!

Post Reply