Tilt disable not working

x64 Replacement/Alternative to Microsoft's IntelliMouse application.
Forum rules
Please read the forum rules before posting for the first time.
The more information you can provide, the quicker and more accurately someone can help.
Post Reply
randorando
New User
Posts: 2
Joined: Tue Sep 04, 2018 6:09 pm

Tilt disable not working

Post by randorando » Tue Sep 04, 2018 6:16 pm

XMBC Version: 2-17
Windows Version: 10 Home
Mouse Information (brand/model): Logitech M325
Computer Information: HP Envy x360
Did the problem occur after an upgrade of XMBC or Windows?:
How long have you used XMBC?: 4 days
What language and keyboard layout do you use in Windows?: EN US

Clear description of the problem:

I have "tilt" left and right set to DISABLE, as they were causing my browser (Chrome) to go "back" and "forward," very annoying when I am just trying to middle-click. XMBC isn't changing the tilt behaviour, however... still just going back and forward.

User avatar
phil
Site Admin
Posts: 5523
Joined: Sun Apr 06, 2003 11:12 pm

Re: Tilt disable not working

Post by phil » Tue Sep 04, 2018 8:12 pm

Strange that TILT goes back/forward in the browser, that not normal behavior...
Ahh perhaps it is with Logitech mice - that is, some Logitech mice - you might be able to change that with Logitech's own software (I can on my mouse and the mouse remembers even when logicteh's software is removed - that mouse dependent though)

When you press the tilt with the XMBC window open, do the dropdown boxes highlight in orange? If not then the mouse is sending some other message which will be why XMBC is not seeing it/disabling it. If they do highlight, then it may be a bug and I will investigate further.

Regards,
Phil
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-6600k, Asus 170-A, 16GB DDR4,
nVidia GeForce GTX 970, 2xEvo 850 (RAID 0), 2x2TB WD Black (RAID1)

randorando
New User
Posts: 2
Joined: Tue Sep 04, 2018 6:09 pm

Re: Tilt disable not working

Post by randorando » Tue Sep 04, 2018 8:17 pm

You provided the clue that solved it.

The tilt buttons on the mouse correspond to buttons 4 and 5, not the actual tilt settings. With this I was able to fix my issue!

(I had already tried the Logitech software... it doesn't recognize the mouse installed!)

User avatar
phil
Site Admin
Posts: 5523
Joined: Sun Apr 06, 2003 11:12 pm

Re: Tilt disable not working

Post by phil » Tue Sep 04, 2018 8:22 pm

Aha, I thought it might translate tilt to 4th and 5th - my Logitech mouse did that before I reconfigured it through their software - actually my mouse a G9 has 3 profiles built in to the hardware and switching between them changed the button behavior in each profile (which I was able to change and store using the Logitech software).

At least you can now disable it :).

Regards,
Phil
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-6600k, Asus 170-A, 16GB DDR4,
nVidia GeForce GTX 970, 2xEvo 850 (RAID 0), 2x2TB WD Black (RAID1)

Post Reply