Blocking the action of modifier keys

x64 Replacement/Alternative to Microsoft's IntelliMouse application.
Forum rules
Please read the forum rules before posting for the first time.
The more information you can provide, the quicker and more accurately someone can help.
Post Reply
sthebemita
New User
Posts: 2
Joined: Thu Aug 09, 2018 10:10 pm

Blocking the action of modifier keys

Post by sthebemita » Fri Aug 10, 2018 12:44 am

Hi, first of all I wanted to say this program is awesome, after using it for a while and memorizing all my custom button chordings it feels so great to use... Now I even feel uncomfortable using another computer that doesn't have XMBC installed! Many thanks to the developer for creating this and introducing so many options for customization.

Recently I ran out of possible key combinations in the default profile and I wanted to use a modifier key to use an extra layer of key combinations. The problem is the modifier key also affects the output of the key combinations, so if I wanted to use CTRL as a modifier and click a key that for example should press "Esc", it will instead press CTRL+Esc. I was wondering if there could be a setting to block the action of the modifier key while a mouse key is being pressed, just like the "block original mouse input" option but for a keyboard modifier key. I don't know if this is more of a feature request or it's something inherent to windows that can't be changed (or maybe it can be achieved using extra software?).

User avatar
phil
Site Admin
Posts: 5608
Joined: Sun Apr 06, 2003 11:12 pm

Re: Blocking the action of modifier keys

Post by phil » Fri Aug 10, 2018 12:52 am

Hi, firstly thanks for the comments :).

Regarding the layer modifier keys - you are not the first to ask and no doubt you will not be the last!
Of course, if you use a modifier key then the fact that the key is pressed, may impact the button action :(.

Unfortunately, the modifier keys are passed through because if they are blocked, the keys will not function (at all - and that would be bad) or introduce lag if they are delayed until it knows if it is intended as a layer change or an actual key. More to the point that would involve simulating the key after the fact (when it knows its not a layer change) and that means the keys may stop working in some programs (games) where it blocks injected/simulated keys.

There may be a workaround although its not as good, you can use global hotkeys to trigger a layer change (which switches the layer permanently even when the key is released) and then a timer to revert the layer (can be set on the layer tab). Its not as effective as modifier keys but it means the key does not have to be held down and does not interfere with the operation of the button.

Regards,
Phil
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-9600k, Asus Z390-ROG, 16GB DDR4,
nVidia GeForce GTX 970, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

sthebemita
New User
Posts: 2
Joined: Thu Aug 09, 2018 10:10 pm

Re: Blocking the action of modifier keys

Post by sthebemita » Fri Aug 10, 2018 1:20 am

Thanks for the explanation! I think I'll use that timer feature for those shortcuts that could be affected by a modifier key.

Edit: I've been looking around in settings and I found the window specific mode, which is even better than using a modifier key since I just have to mode the mouse to a certain part of the screen and trigger the other profile. That "hidden" option is great!

Post Reply