left mouse mapped to down arrow & can't change

x64 Replacement/Alternative to Microsoft's IntelliMouse application.
Forum rules
Please read the forum rules before posting for the first time.
The more information you can provide, the quicker and more accurately someone can help.
Post Reply
rufflechip
New User
Posts: 2
Joined: Sat Jun 09, 2018 2:39 am

left mouse mapped to down arrow & can't change

Post by rufflechip » Sat Jun 09, 2018 2:52 am

XMBC Version: fresh download, I uninstalled, but the problem doesn't go away / tried to restore but restore didn't work either
Windows Version: windows 10 pro
Mouse Information (brand/model): dell on the desktop Dell 3 button & on the floor savant elite 2
Computer Information: 64 bit i5-7500 cpu
Did the problem occur after an upgrade of XMBC or Windows?: no
How long have you used XMBC?: about 30 minutes
What language and keyboard layout do you use in Windows?: English & standard

Clear description of the problem:

Hi:

I'm a complete newbie here, and I was really liking the application, but I must not understand something. I wanted to use my footpad left mouse click to simulate the left down arrow for a certain application only. I set it up for the application and left the default standard. Everything appeared to be working fine for about 5 minutes, but all of a suddend the controls seem to be fixed to always using left mouse as arrow down even when I do a reboot.

Is there a way to open up the x-control application without allowing it to automatically start simulating? Without using the left mouse key of all things!

I've uninstalled and re-installed several times & this is somehow being "remembered."

Thanks!

User avatar
phil
Site Admin
Posts: 5501
Joined: Sun Apr 06, 2003 11:12 pm

Re: left mouse mapped to down arrow & can't change

Post by phil » Sat Jun 09, 2018 9:33 am

Hi and Welcome!

The answer will depend how you have set up XMBC (what other options are on/off).... It sounds like either the profile is wrong and getting activated all the time, or you accidentally setup something for the left button on the default profile! To recover, you can try the following...

1. If you have "disable XMBC when scroll lock is on", turn on scroll lock to disable XMBC temporarily.
2. If you can still use the right mouse button, right click the XMBC icon (in the system tray) and select disable to disable XMBC (using arrow keys/enter). You may have some trouble finding the XMBC icon if its hidden away in the ^ extended system tray - as I don't know
3. Run XMBC from the start menu (for a second time) this should cause the configuration screen to open. Then use TAB/Arrow keys to move around the controls in XMBC to change the configuration of the left button.
4. Delete/Rename the XMBC settings file and reboot (or kill XMBC using task manager (and the keyboard to navigate around it) and re-run it) - this is a little bit over the top only do this as a last resort!

Thanks,
Phil
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-6600k, Asus 170-A, 16GB DDR4,
nVidia GeForce GTX 970, 2xEvo 850 (RAID 0), 2x2TB WD Black (RAID1)

Post Reply