Page 1 of 1

Caption matching is not working when switch tab in browser

Posted: Thu Apr 19, 2018 10:14 pm
by mp20012
XMBC Version: 2.17
Windows Version: 10 x64
Mouse Information (brand/model): Logitech M560
Computer Information:
Did the problem occur after an upgrade of XMBC or Windows?: no
How long have you used XMBC?: 5hrs
What language and keyboard layout do you use in Windows?: JP

Clear description of the problem:
I use caption matching to re-configure buttons in specific tabs/sites. For example, use re-configure button in gmail but use the default function of button in other sites.
However, caption matching is not working when I switch tab in browser. For example, switch to other tab/site then go back to gmail tab. The re-configure function for gmail will not work. I need to switch to other window and go back to browser window to re-match the caption. After re-matching caption, the re-configure button is working again.
Are there any settings in XMBC that can check the changing of caption when switch tab?

Re: Caption matching is not working when switch tab in browser

Posted: Fri Apr 20, 2018 7:48 am
by phil
Yes this is well known and actually intentional. Due to the high resource usage for caption matching, pattern matching only runs when the active application changes. When switching tabs, the active window/exe is the same, so its not run :(.

Actually, in 2.18, I have reduced the resource usage somewhat, so it may be possible to re-run the match but not every time the mouse moves (thats still going 5to be bad) but perhaps when a button is clicked.... (wont help if switching tabs via the keyboard). Perhaps it needs a per profile option to turn this on, so its only applied for applications where the caption can change, like a browser... that may be enough to prevent it from overloading the CPU all the time...