2.11.1 -> 2.17: Change Movement to Scroll stopped working

x64 Replacement/Alternative to Microsoft's IntelliMouse application.
Forum rules
Please read the forum rules before posting for the first time.
The more information you can provide, the quicker and more accurately someone can help.
Post Reply
Chainfire
New User
Posts: 2
Joined: Mon Apr 16, 2018 8:28 pm

2.11.1 -> 2.17: Change Movement to Scroll stopped working

Post by Chainfire » Mon Apr 16, 2018 8:35 pm

XMBC Version: 2.17
Windows Version: 7
Mouse Information (brand/model): Logitech Marble Mouse
Computer Information: N/A
Did the problem occur after an upgrade of XMBC or Windows?: Yes
How long have you used XMBC?: Years
What language and keyboard layout do you use in Windows?: US-International

Clear description of the problem:
When upgrading from XMBC 2.11.1 to 2.17 "Change Movement to Scroll (Sticky)" stops working. When I press the button, I do get the hand cursor with arrow inside of it, but then moving the trackball just moves that cursor around 1-pixel in each direction but no scrolling occurs.

Reverting to 2.11.1 fixes the issue and scrolling works fine again.

This is literally all I use XMBC for, it is the only option I have configured.

User avatar
phil
Site Admin
Posts: 5455
Joined: Sun Apr 06, 2003 11:12 pm

Re: 2.11.1 -> 2.17: Change Movement to Scroll stopped working

Post by phil » Tue Apr 17, 2018 7:48 am

change movement to scroll was changed quite considerably between 2.11 and 2.17 (I can remember which version specifically) but now you have one change movement to scroll and a configuration window to set it up. It is possible the the "upgrade" didn't quite get the settings right and you need to open the configuration and adjust to suit your device (for example, the sensitivity).

If that does not help, I would need to see some debug log from 2.17 to try and understand what is going on. There is another change scheduled for 2.18 to give better acceleration etc. I haven't got round to that yet so if there is a problem then there is an ideal point to fix anything else!

Thanks,
Phil
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-6600k, Asus 170-A, 16GB DDR4,
nVidia GeForce GTX 970, 2xEvo 850 (RAID 0), 2x2TB WD Black (RAID1)

Chainfire
New User
Posts: 2
Joined: Mon Apr 16, 2018 8:28 pm

Re: 2.11.1 -> 2.17: Change Movement to Scroll stopped working

Post by Chainfire » Tue Apr 17, 2018 4:00 pm

Playing around some more, I've gotten it to work if I disable 'sticky' mode. I can't find any way to get it to work with sticky enabled, which is a shame because that's how I like to use it :)

Debug logs: drive dot google dot com /file/d/1vw7Bdm1DkvSSxpiWlf9grX6_ZaEgWBIM/view?usp=sharing

First I did some scrolling non-sticky (which works), then I did some sticky scrolling (which doesn't do anything). Hope you can fix this.

PS. You're making it hard to share logs when I can't post URLs, posts long enough to contain the logs, or create attachments...

User avatar
phil
Site Admin
Posts: 5455
Joined: Sun Apr 06, 2003 11:12 pm

Re: 2.11.1 -> 2.17: Change Movement to Scroll stopped working

Post by phil » Tue Apr 17, 2018 4:56 pm

You will be able to post URLs once you have at least 3 or 4 posts - this is to reduce spam (which is an ever increasing problem).
I'm starting to think there may be some issues with sticky buttons in 2.17 (there were but I'm not sure if this was one of them), that I may have fixed in 2.18 - I'll try and take a look and see if it is something I have already addressed!
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-6600k, Asus 170-A, 16GB DDR4,
nVidia GeForce GTX 970, 2xEvo 850 (RAID 0), 2x2TB WD Black (RAID1)

Post Reply