X-Mouse Not Working

x64 Replacement/Alternative to Microsoft's IntelliMouse application.
Forum rules
Please read the forum rules before posting for the first time.
The more information you can provide, the quicker and more accurately someone can help.
Post Reply
FrostDrive
New User
Posts: 2
Joined: Thu Mar 15, 2018 6:18 pm

X-Mouse Not Working

Post by FrostDrive » Thu Mar 15, 2018 6:27 pm

Lately X-mouse Buttons are not working.

The buttons seem to act like normal. LIke X-mouse is doing nothing.

I've tried having the buttons configured on the default, and with a program specific setting. Nothing works.

The buttons I"m configuring are just simple letters. Middle mouse to "i" for example. These are to select tools in an art program.

Nothing is working though.

I had this issue seldom in the past and a simple restart would fix it.

But now restarting does not help.

Uninstalling and reinstalling did not help.

Unplugging mouse did not help.

Please help me.

User avatar
phil
Site Admin
Posts: 5447
Joined: Sun Apr 06, 2003 11:12 pm

Re: X-Mouse Not Working

Post by phil » Thu Mar 15, 2018 6:32 pm

Whats changed?
What version of XMBC (now and previously)?
What version of Windows?
What reason you didn't provide basic the information requested in the posting rules?

Any errors in the log file?
Some debug log file would be good to see here... Turn on debug logging and capture the problem (press some buttons) then send me the log file (by PM or email)

Thanks,
Phil
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-6600k, Asus 170-A, 16GB DDR4,
nVidia GeForce GTX 970, 2xEvo 850 (RAID 0), 2x2TB WD Black (RAID1)

User avatar
Kukurykus
Committed
Posts: 171
Joined: Sat Jul 02, 2016 1:15 pm

Re: X-Mouse Not Working

Post by Kukurykus » Thu Mar 15, 2018 7:40 pm

I am sorry for off-topic again, but maybe it would be possible whenever someone makes new topic (so not make another post to existing topic) there is automaticaly pasted short informational text - that you each time put on top of your reply when you miss these informations. When they're not necessary for someone's new topic that person could easily press ctrl a to mark text area and overwrite those information with new text :) The question is would be it possible to do (with/out some plug-in) and would not that affect next forums upgrades again ;)
HAMA Roma, Rapoo 3920P
Windows 10 x64, Intel i5-4670K @ 3.40GHz, 8GB,
Intel(R) HD Graphics 4600, Intel SSD 179 GB HDD

FrostDrive
New User
Posts: 2
Joined: Thu Mar 15, 2018 6:18 pm

Re: X-Mouse Not Working

Post by FrostDrive » Fri Mar 16, 2018 9:40 pm

I did the debug.
It says this message a million times.

MouseHookLLProc: Injected message was modified by something else therefore we could have a problem!


Windows 10
Using latest XMBC

User avatar
phil
Site Admin
Posts: 5447
Joined: Sun Apr 06, 2003 11:12 pm

Re: X-Mouse Not Working

Post by phil » Sat Mar 17, 2018 12:31 pm

That's interesting... can you send me the debug log (via PM or email)

Without looking, it sounds like something else is hooking the mouse messages and getting to them before XMBC does.... Thats going to be difficult to diagnose (as there is nothing in Windows that lets you see what has "hooked" into the message chain). but have you installed anything else recently that is designed to manipulate mouse buttons or keyboard keys?
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-6600k, Asus 170-A, 16GB DDR4,
nVidia GeForce GTX 970, 2xEvo 850 (RAID 0), 2x2TB WD Black (RAID1)

Post Reply