XMBC 2.17: Problem with Sticky Left Button X & Y axis

x64 Replacement/Alternative to Microsoft's IntelliMouse application.
Forum rules
Please read the forum rules before posting for the first time.
The more information you can provide, the quicker and more accurately someone can help.
Post Reply
User avatar
Ville
Member
Posts: 18
Joined: Sun Mar 27, 2011 5:18 am

XMBC 2.17: Problem with Sticky Left Button X & Y axis

Post by Ville » Mon Jan 22, 2018 12:12 am

With 2.17 there's something wrong with the "Sticky Left Button [click-drag]" option for both X and Y axis. I have it assigned to the "button 5" of my trackball, and when engaged, it will not disengage on the second click of the button 5. When I (cumbersomely) manage to exit the program with only one axis of mouse-movement working, the cursor is left with the vertical or horizontal two-way arrow. After restarting the program, if I then engage the opposite axis (set on a different layer), the mouse which was free-moving after the restart, becomes paralyzed altogether (making exiting the program even more fun :) ). I do have a lot of utilities installed, so it's possible there's interaction with something else, but this is something that I started seeing recently, likely after I upgraded to 2.17.

Let me know if I can provide additional debug detail!

User avatar
phil
Site Admin
Posts: 5399
Joined: Sun Apr 06, 2003 11:12 pm

Re: XMBC 2.17: Problem with Sticky Left Button X & Y axis

Post by phil » Mon Jan 22, 2018 2:22 am

Hi, yes the debug log might be useful.
If you need a copy of 2.16(.1) to go back and test with that too (to be sure its 2.17) then let me know and I'll send the link tomorrow!
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-6600k, Asus 170-A, 16GB DDR4,
nVidia GeForce GTX 970, 2xEvo 850 (RAID 0), 2x2TB WD Black (RAID1)

User avatar
Ville
Member
Posts: 18
Joined: Sun Mar 27, 2011 5:18 am

Re: XMBC 2.17: Problem with Sticky Left Button X & Y axis

Post by Ville » Wed Jan 24, 2018 4:43 am

I finally had the opportunity to look at this further (mainly, close all of my ~200 open Chrome tabs so that I could restart and make sure it wasn't a temporary glitch — it wasn't). Attached is the debug log. Also, note that the year on the log has gone crazy (or I have inadvertently time-traveled to year 3918... but unfortunately Trump, or someone who looks very much like him, is still the president of the U.S.).

Note that on the second depress of the configured axis lock button, the 'drag-lock' on the selected axis is released, but the cursor is not freed to move freely in the non-selected axis.
You do not have the required permissions to view the files attached to this post.

User avatar
phil
Site Admin
Posts: 5399
Joined: Sun Apr 06, 2003 11:12 pm

Re: XMBC 2.17: Problem with Sticky Left Button X & Y axis

Post by phil » Thu Jan 25, 2018 2:09 am

OK, I'll try and take a look when I get a spare moment... I'm a bit busy this weekend so prob not before Sunday (or later)...
I'll get back to you here when I find/need something!
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-6600k, Asus 170-A, 16GB DDR4,
nVidia GeForce GTX 970, 2xEvo 850 (RAID 0), 2x2TB WD Black (RAID1)

User avatar
Ville
Member
Posts: 18
Joined: Sun Mar 27, 2011 5:18 am

Re: XMBC 2.17: Problem with Sticky Left Button X & Y axis

Post by Ville » Thu Jan 25, 2018 9:06 am

No hurry! But if you could send me a link to the previous release version, I could confirm that the problem doesn't exist with it, and also then keep using it while you're debugging the current one. It seems I hadn't kept the previous version..

User avatar
phil
Site Admin
Posts: 5399
Joined: Sun Apr 06, 2003 11:12 pm

Re: XMBC 2.17: Problem with Sticky Left Button X & Y axis

Post by phil » Thu Jan 25, 2018 9:20 am

2.16.1: https://www.highrez.co.uk/scripts/downl ... on=2160100
2.15: https://www.highrez.co.uk/scripts/downl ... on=2150000
NOTE You can just change the numbers in the URL to get different (older) versions that are still on the server :)
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-6600k, Asus 170-A, 16GB DDR4,
nVidia GeForce GTX 970, 2xEvo 850 (RAID 0), 2x2TB WD Black (RAID1)

User avatar
Ville
Member
Posts: 18
Joined: Sun Mar 27, 2011 5:18 am

Re: XMBC 2.17: Problem with Sticky Left Button X & Y axis

Post by Ville » Thu Jan 25, 2018 10:40 pm

Thanks! 2.16.1 works fine. I tried once more to reinstall 2.17 to make sure I didn't have a corrupted installation earlier, but the problem did indeed come back, so the problem was positively introduced in 2.17.

User avatar
phil
Site Admin
Posts: 5399
Joined: Sun Apr 06, 2003 11:12 pm

Re: XMBC 2.17: Problem with Sticky Left Button X & Y axis

Post by phil » Sat Feb 03, 2018 1:19 pm

Well the good news (I guess) is that the same problem happens here - that will make finding and fixing it much easier :).
I'll fix it for the next <beta> version.

EDIT: 5 minutes later and its fixed... Silly mistake :( I guess this is not a frequently used feature so we missed it in the beta testing phase of 2.17 - it got introduced in 2.17 Beta 10. 2.18 Beta 1 will fix this when I get round to releasing it (not sure when that will be as Ive only made 2 little fixes so far, nothing big or new to deserve a new beta (ie. I really need to get some time to implement some of the bigger changes that have been requested!).
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-6600k, Asus 170-A, 16GB DDR4,
nVidia GeForce GTX 970, 2xEvo 850 (RAID 0), 2x2TB WD Black (RAID1)

User avatar
Ville
Member
Posts: 18
Joined: Sun Mar 27, 2011 5:18 am

Re: XMBC 2.17: Problem with Sticky Left Button X & Y axis

Post by Ville » Sat Feb 10, 2018 10:07 am

Hi Phil! That sounds great! I was out of town for a few days and just noticed your update.

I use the feature quite frequently as I'm a trackball user, and the Y-lock especially makes it very handy to scroll through long documents. 2.16.1 works fine 'til the next version comes about (so no hurry because of this).

Post Reply