Windows 7 problems when left<>right buttons swapped

x64 Replacement/Alternative to Microsoft's IntelliMouse application.
Forum rules
Please read the forum rules before posting for the first time.
The more information you can provide, the quicker and more accurately someone can help.
NOTE: To reduce spam, new users can not post links or images until they have at least 4 posts.
Post Reply
DaveApp
New User
Posts: 1
Joined: Sat Nov 21, 2009 4:52 pm

Windows 7 problems when left<>right buttons swapped

Post by DaveApp » Sat Nov 21, 2009 6:02 pm

Thanks for your excellent XMBC application, which I recently installed.
Unfortunately I am having some small irritations with it not working perfectly in some circumstances.

I have a Logitech mouse with four buttons (Left, Middle, Right, Side) and a scroll wheel. The Logitech drivers are not installed as all buttons function without them.
I have set Left=right click, Right=left click, Middle=minimise, Side=double left click.

Using XP Pro everything works fine apart from those applications set to minimise to the system tray.
A couple of examples:
Foxit Reader 3.1.3.1030 minimises to the taskbar rather than the tray on clicking my middle button but otherwise works fine.
KMPlayer 2.9.4.1436 also minimises (initially) to the taskbar but cannot be restored, it attempts but fails, staying determinedly in the taskbar.

I have the release candidate for Windows 7 Enterprise on my second disc & here I have some problems with the left/right buttons. Some system operations get confused regarding which button is which.
A couple of examples:
After navigating to "Recovery" via Control Panel,
In the dialogue "Restore this computer to an earlier point in time", clicking my right button on "Open System Restore" takes me to the next dialogue, as expected.
Now at "Restore system files and settings" I need to use the left button to either dismiss this dialogue or proceed - somehow Windows is collaring my click before XMBC has the chance to intercept.
The second similar example is when starting (e.g.) regedit from the Run dialogue.
In Run the right button operates as expected.
I then get a "User Account Control" dialogue, but it seems to have lost focus.
None of my buttons initially has any effect until focus is restored by going round the open apps with <ALT><TAB>. Once that's been done I can use the left button rather than the right to dismiss the dialogue or proceed.
The loss of focus issue on the UAC dialogue occurs whenever XMBC is set to intercept a left click.

Whilst the above problems are irritating, they are fairly minor. The minimise problem can be avoided by not setting the middle button to minimise in KMP!
The Windows 7 problems can easily be worked round by setting XMBC to not intercept the left and right buttons. These can be swapped in Control Panel's Mouse dialogue. Doing that solves both the examples I've mentioned.

Thanks again for an excellent piece of work.

p.s. You repeatedly spell repeatedly wrongly! (a typo?)

Dave

Post Reply