Page 1 of 1

Elecom Scope Node Mouse Still Not Working

Posted: Wed Nov 11, 2009 1:33 am
by zacheadams
After a lot of rolling around these here internets, I have still been unable to find a solution to my problem, and now I'm wondering if there's either no solution or if the mouse I have is broken. I am somewhat doubtful of the latter.

I ordered a few months back an Elecom Scope Node (wired) mouse. It's a really beautiful piece of machinery, but it's just a paperweight until I can get it working (of which I REALLY want). I've downloaded the newest XMBC, as was recommended on one of the top sites on a Google search for "Elecom Scope Node Drivers", but nothing :(

Another forum member has apparently had success on his Windows XP 32-bit PC, but I have had none on my Windows 7 64-bit PC. Windows says that there are no drivers installed for the mouse when I plug it in and the internet yields none (since the product page when translated from Japanese says "no drivers required").

Anyone had any success here, any ideas?

Re: Elecom Scope Node Mouse Still Not Working

Posted: Wed Nov 11, 2009 1:51 am
by phil
Well its not a device I have heard of.

If windows cant even find a driver for it, then it sounds like your in trouble. And these days that's quite rare, esp. with MS's move to insist on 64bit drivers before the windows logo can be given... But even more rare not to get even basic functionality with the default HID driver. I take it that nothing is working at all (even basic mouse functionality)?

My only suggestion would be to contact the manufacturer and ask where their 64bit drivers are!

To test the mouse, can you find a 32bit machine to try it in (or use a 32bit virtual machine guest - XP Mode maybe?) and connect the USB device directly to the guest OS?

Maybe someone else here can help, but these here bits of the interwebs are rather quiet :(