Bug with XMBC and infrared remote

x64 Replacement/Alternative to Microsoft's IntelliMouse application.
Forum rules
Please read the forum rules before posting for the first time.
The more information you can provide, the quicker and more accurately someone can help.
Post Reply
Archway
New User
Posts: 4
Joined: Sat Apr 09, 2016 5:12 pm

Bug with XMBC and infrared remote

Post by Archway » Wed Dec 27, 2017 1:44 pm

I am very grateful for XMBC - much better than the logitech drivers!

On a Windows 10 1709 x64 machine configured as a media centre in that both imon.exe (remote control etc. software) and kodi.exe (issue occurs regardless of whether version 7.x or 8) both start automatically I have XMBC installed mainly because I do maintenance from another computer via remote desktop. The media centre has a mini combined wireless keyboard/mouse for use when needed as well.

Some months, maybe over a year ago, I noticed that the infrared remote was not working properly to control kodi. Until I had operated the wireless mouse to do something in kodi, e.g. select a menu, the infrared did not work. Once the wireless mouse had been used once, the infrared worked normally thereafter. Wierd!!

After a lot of trial and error I found that disabling or removed XMBC fixed the problem - the infrared now controlled kodi straight away, as it should.

The longer term fix was to install an earlier version of XMBC - there is no problem using 2.10.2. I dont know exactly with which version of XMBC this first appeared. I mention it not because I need a fix, as I have a workaround using an earlier version, but in case it reflects a more general, if obscure, problem which you might wish to investigate.

Thanks again for a very useful program.

User avatar
phil
Site Admin
Posts: 5471
Joined: Sun Apr 06, 2003 11:12 pm

Re: Bug with XMBC and infrared remote

Post by phil » Wed Dec 27, 2017 4:13 pm

Thanks for the info (I think).
I cant think of any particular reason for this, other than maybe there is some windows hook conflicts (XMBC uses mouse and keyboard hooks and maybe this gets in the way of the remote software). But that does not really explain why 2.10.2 works!

As to investigating - unfortunately, while I do have a simular media PC setup, I dont use irmon on it (because the irda sensor is connected to another PC which uses eventghost and communicates over the LAN with the media PC) - so its not going to be easy to change my setup to test with irmon.
Without being able to reproduce the problem here (easily) I'm not sure where to start!

Thanks for letting me (and others) know about it though.
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-6600k, Asus 170-A, 16GB DDR4,
nVidia GeForce GTX 970, 2xEvo 850 (RAID 0), 2x2TB WD Black (RAID1)

Post Reply