Initial wait {wait:x or waitms:x} ignored when layer switch added {layer:x}

x64 Replacement/Alternative to Microsoft's IntelliMouse application.
Forum rules
Please read the forum rules before posting for the first time.
The more information you can provide, the quicker and more accurately someone can help.
Post Reply
xerkon
New User
Posts: 10
Joined: Wed Nov 22, 2017 4:03 pm

Initial wait {wait:x or waitms:x} ignored when layer switch added {layer:x}

Post by xerkon » Tue Dec 19, 2017 1:50 am

Set button to {wait:5}1 and there is a five second delay before 1 is pressed. Change button to {wait:5}1{layer:x) and now 1 is pressed immediately.

User avatar
phil
Site Admin
Posts: 5418
Joined: Sun Apr 06, 2003 11:12 pm

Re: Initial wait {wait:x or waitms:x} ignored when layer switch added {layer:x}

Post by phil » Tue Dec 19, 2017 1:56 am

Odd... I'll take a look. What version of XMBC? 2.16.1 OR 2.17 Beta?
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-6600k, Asus 170-A, 16GB DDR4,
nVidia GeForce GTX 970, 2xEvo 850 (RAID 0), 2x2TB WD Black (RAID1)

User avatar
phil
Site Admin
Posts: 5418
Joined: Sun Apr 06, 2003 11:12 pm

Re: Initial wait {wait:x or waitms:x} ignored when layer switch added {layer:x}

Post by phil » Tue Dec 19, 2017 2:27 pm

Yes confirmed, I will fix it in the next beta (today probably).
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-6600k, Asus 170-A, 16GB DDR4,
nVidia GeForce GTX 970, 2xEvo 850 (RAID 0), 2x2TB WD Black (RAID1)

xerkon
New User
Posts: 10
Joined: Wed Nov 22, 2017 4:03 pm

Re: Initial wait {wait:x or waitms:x} ignored when layer switch added {layer:x}

Post by xerkon » Wed Dec 20, 2017 7:34 am

:D Thanks Phil for caring about X-Mouse. I just saw the new beta with the fixes! If all software engineers were more like you the world would undoubtedly be a better place! :cheers:

Post Reply