Mouse speed bug

x64 Replacement/Alternative to Microsoft's IntelliMouse application.
Forum rules
Please read the forum rules before posting for the first time.
The more information you can provide, the quicker and more accurately someone can help.
Post Reply
dinu
New User
Posts: 12
Joined: Mon Jul 17, 2017 9:09 am

Mouse speed bug

Post by dinu » Fri Oct 27, 2017 2:18 pm

I have a high-res mouse so the control panel mutiplier is set to the lowest level via a third party app that switches dynamically between devices I use (trackpad, high-res mouse, another low-res mouse).

However, whe the following happens, the multiplier gets reset to the default value:
- When I close the XMBC window (gets minimized to tray)
- When unlocking windows (lock/unlock)
The "override mouse speed" is disabled in XMBC profile, but I assume it writes values from Settings/General anyway. There should be a way to disable this behaviour.

dinu
New User
Posts: 12
Joined: Mon Jul 17, 2017 9:09 am

Re: Mouse speed bug

Post by dinu » Fri Oct 27, 2017 2:26 pm

Note: the setting seems also inconsistent, it does not apply the same setting on windows startup for instance. Only on app close or lock/unlock cycle.

User avatar
phil
Site Admin
Posts: 5533
Joined: Sun Apr 06, 2003 11:12 pm

Re: Mouse speed bug

Post by phil » Fri Oct 27, 2017 3:37 pm

Well firstly, what version of XMBC? There was an issue in earlier versions where it wrote the wrong thing. This should be fixed in 2.16.1

Secondly, XMBC should not be doing anything on lock/unlock (unless the lock was actually sleep/hibernate).

I will have to investigate further when I get some spare time. The speed control in XMBC does write to the system setting, but only if you have actually set it/changed it, and it should read the system setting on startup and reset it on shutdown so if you don't change it in between it shouldn't change!

Thinking a little more about it, if you have an app that is changing it while XMBC is running then I can see how this might be a problem - and it probably explains your issues... I will have to put some code in XMBC to detect when other apps change this setting... What app is that (and how does it know what device is running I wonder - because I have already got things on my todo list to try and detect the active device to enable/disable XMBC).

Thanks,
Phil
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-6600k, Asus 170-A, 16GB DDR4,
nVidia GeForce GTX 970, 2xEvo 850 (RAID 0), 2x2TB WD Black (RAID1)

dinu
New User
Posts: 12
Joined: Mon Jul 17, 2017 9:09 am

Re: Mouse speed bug

Post by dinu » Fri Oct 27, 2017 5:08 pm

The program is EitherMouse - it's a tiny little program, I don't know how it detects the device that generated the mouse movement, but it does so quite well.

I have XMBC 2.16.1

Post Reply