Strange issue...

x64 Replacement/Alternative to Microsoft's IntelliMouse application.
Forum rules
Please read the forum rules before posting for the first time.
The more information you can provide, the quicker and more accurately someone can help.
Post Reply
User avatar
injtsvetkov
Fanatic
Posts: 257
Joined: Mon Jun 06, 2016 8:51 am

Strange issue...

Post by injtsvetkov » Fri Sep 08, 2017 12:49 am

It happened twice but I don't know how I triggered it (v2.17 Beta 5).
The first time it happened I had explorer window focused and when I left-clicked in it the window got unfocused (?). I realized that both LMB and RMB are not working and used hotkey to open XMBC but when I left-clicked in the Settings window it got unfocused too. However every button I press gets highlighted like it should, it just doesn't do anything! Then I right-clicked the tray icon (surprisingly it worked :roll:) and disabled XMBC from the context menu, then I reenabled it and everything was fine.
Next time it happened in excel. I left-clicked in a cell but the LMB got stuck (held down). I disabled and reenabled XMBC via hotkey but it did not help! I activated debug mode via hotkey, left-clicked once and then right-clicked once, then I deactivated debug mode. After that I closed excel and the problem disappeared.

Code: Select all

07-09-3917 21:46:11.117> X-Mouse Button Control v2.17 Beta 5 (x64) Startup. Commandline '/notportable /delay'
07-09-3917 21:46:11.333> Running in high integrity mode (0x00003000)
07-09-3917 21:46:11.552> Loaded 14 application specific profiles (7 normal and 7 custom window).
07-09-3917 21:46:11.568> Running on Microsoft Windows 8.1 Home Edition (build 9600), 64-bit, Hook Timeout: 1000 ms
07-09-3917 21:46:11.599> Startup folder: 'C:\Program Files\Highresolution Enterprises\X-Mouse Button Control\'
07-09-3917 21:46:11.599> Settings (and log) folder: 'C:\Users\user\AppData\Roaming\Highresolution Enterprises\XMouseButtonControl\'
07-09-3917 21:46:11.630> Using keyboard language 0x04090409
07-09-3917 21:46:11.677> SetHotkeys installed 8 global hotkeys...
07-09-3917 21:48:11.999> You are using the latest available version of X-Mouse Button Control.
07-09-3917 22:19:51.635> CMyMessageWnd::OnSetup   -   Opening setup dialog.
07-09-3917 22:19:51.776> Loaded 14 application specific profiles (7 normal and 7 custom window).
07-09-3917 22:23:50.512> Removing any active XMBCHook Timers...
07-09-3917 22:23:50.512> CSendInput: Exiting SendInput thread.
07-09-3917 22:23:50.512> Hook thread exited with error code 0.
07-09-3917 22:23:50.512> Timer thread exited with error code 0.
07-09-3917 22:23:50.512> SetHotkeys installed 3 global hotkeys...
07-09-3917 22:23:52.767> CMyMessageWnd::OnSetup   -   Setup dialog closed.
07-09-3917 22:23:52.783> Loaded 14 application specific profiles (7 normal and 7 custom window).
07-09-3917 22:23:52.783> SetHotkeys installed 3 global hotkeys...
07-09-3917 22:23:57.773> You are using the latest available version of X-Mouse Button Control.
07-09-3917 22:24:00.661> Loaded 14 application specific profiles (7 normal and 7 custom window).
07-09-3917 22:24:00.661> Using keyboard language 0x04090409
07-09-3917 22:24:00.661> SetHotkeys installed 8 global hotkeys...
07-09-3917 22:24:54.745> CMyMessageWnd::OnSetup   -   Opening setup dialog.
07-09-3917 22:24:54.768> Loaded 14 application specific profiles (7 normal and 7 custom window).
07-09-3917 22:25:16.671> CMyMessageWnd::OnSetup   -   Setup dialog closed.
07-09-3917 22:25:16.702> Loaded 14 application specific profiles (7 normal and 7 custom window).
07-09-3917 22:25:16.702> SetHotkeys installed 8 global hotkeys...
07-09-3917 22:25:17.760> Removing any active XMBCHook Timers...
07-09-3917 22:25:17.760> CSendInput: Exiting SendInput thread.
07-09-3917 22:25:17.760> Hook thread exited with error code 0.
07-09-3917 22:25:17.760> Timer thread exited with error code 0.
07-09-3917 22:25:17.760> SetHotkeys installed 3 global hotkeys...
07-09-3917 22:25:18.334> Loaded 14 application specific profiles (7 normal and 7 custom window).
07-09-3917 22:25:18.349> Using keyboard language 0x04090409
07-09-3917 22:25:18.349> SetHotkeys installed 8 global hotkeys...
07-09-3917 22:25:21.719> You are using the latest available version of X-Mouse Button Control.
07-09-3917 22:33:39.716> Removing any active XMBCHook Timers...
07-09-3917 22:33:39.716> CSendInput: Exiting SendInput thread.
07-09-3917 22:33:39.716> Hook thread exited with error code 0.
07-09-3917 22:33:39.716> Timer thread exited with error code 0.
07-09-3917 22:33:39.716> SetHotkeys installed 3 global hotkeys...
07-09-3917 22:33:43.560> Loaded 14 application specific profiles (7 normal and 7 custom window).
07-09-3917 22:33:43.560> Using keyboard language 0x04090409
07-09-3917 22:33:43.560> SetHotkeys installed 8 global hotkeys...
07-09-3917 22:34:59.773> CMyMessageWnd::OnSetup   -   Opening setup dialog.
07-09-3917 22:34:59.789> Loaded 14 application specific profiles (7 normal and 7 custom window).
07-09-3917 22:35:04.954> CMyMessageWnd::OnSetup   -   Setup dialog closed.
07-09-3917 22:35:04.970> Loaded 14 application specific profiles (7 normal and 7 custom window).
07-09-3917 22:35:04.970> SetHotkeys installed 8 global hotkeys...
07-09-3917 22:35:09.988> You are using the latest available version of X-Mouse Button Control.
07-09-3917 22:35:11.059> CMyMessageWnd::OnSetup   -   Opening setup dialog.
07-09-3917 22:35:11.090> Loaded 14 application specific profiles (7 normal and 7 custom window).
07-09-3917 22:35:19.842> CMyMessageWnd::OnSetup   -   Setup dialog closed.
07-09-3917 22:35:19.858> Loaded 14 application specific profiles (7 normal and 7 custom window).
07-09-3917 22:35:19.874> SetHotkeys installed 8 global hotkeys...

>>>>>>>>>>>>>>>>>>>>07-09-3917 22:35:24.259> Enabling extra debug logging.>>>>>>>>>>>>>>>>>>>>
07-09-3917 22:35:24.337> KeyHookLLProc: Resetting mouse cursor speed to 10 after 'Slowdown by key'
07-09-3917 22:35:24.384> KeyHookLLProc: Resetting mouse cursor speed to 10 after 'Slowdown by key'
07-09-3917 22:35:24.869> Checkversion: Got DNS response: 02160100. date 42954
07-09-3917 22:35:24.869> Checkversion: Got BETA DNS response: 02169906. date 42954
07-09-3917 22:35:24.869> You are using the latest available version of X-Mouse Button Control.
07-09-3917 22:35:25.759> GetWindowCaption: WM_GETTEXT returned 'Razhod.xls'
07-09-3917 22:35:25.790> MouseHookLLProc: MouseHookData: Msg=0x0201 (WM_LBUTTONDOWN), X=963, Y=417, Data=0x00000000, Flags=0x00000000, Time=693312578, Info=0x0, Ptr=0x5D0EE7, Layer=0
07-09-3917 22:35:25.790> Translating Left Button Down Key state 0x10: Action 40 [** No Change (Don't intercept) **]
07-09-3917 22:35:25.790> MouseHookLLProc: Passing original mouse message 00000201 through....
07-09-3917 22:35:25.938> MouseHookLLProc: MouseHookData: Msg=0x0202 (WM_LBUTTONUP), X=963, Y=417, Data=0x00000000, Flags=0x00000000, Time=693312718, Info=0x0, Ptr=0x5D0EE7, Layer=0
07-09-3917 22:35:25.938> Translating Left Button Up Key state 0x11: Action 40 [** No Change (Don't intercept) **]
07-09-3917 22:35:25.938> MouseHookLLProc: Passing original mouse message 00000202 through....
07-09-3917 22:35:26.366> GetWindowCaption: WM_GETTEXT returned 'Razhod.xls'
07-09-3917 22:35:26.522> GetWindowCaption: WM_GETTEXT returned 'Razhod.xls'
07-09-3917 22:35:26.710> GetWindowCaption: WM_GETTEXT returned 'Razhod.xls'
07-09-3917 22:35:26.866> GetWindowCaption: WM_GETTEXT returned 'Razhod.xls'
07-09-3917 22:35:27.034> GetWindowCaption: WM_GETTEXT returned 'Razhod.xls'
07-09-3917 22:35:27.164> MouseHookLLProc: MouseHookData: Msg=0x0201 (WM_LBUTTONDOWN), X=1172, Y=415, Data=0x00000000, Flags=0x00000000, Time=693313953, Info=0x0, Ptr=0x5D0EE7, Layer=0
07-09-3917 22:35:27.164> Translating Left Button Down Key state 0x10: Action 40 [** No Change (Don't intercept) **]
07-09-3917 22:35:27.164> MouseHookLLProc: Passing original mouse message 00000201 through....
07-09-3917 22:35:27.289> MouseHookLLProc: MouseHookData: Msg=0x0202 (WM_LBUTTONUP), X=1172, Y=415, Data=0x00000000, Flags=0x00000000, Time=693314078, Info=0x0, Ptr=0x5D0EE7, Layer=0
07-09-3917 22:35:27.289> Translating Left Button Up Key state 0x11: Action 40 [** No Change (Don't intercept) **]
07-09-3917 22:35:27.289> MouseHookLLProc: Passing original mouse message 00000202 through....
07-09-3917 22:35:27.320> GetWindowCaption: WM_GETTEXT returned 'Razhod.xls'
07-09-3917 22:35:28.944> GetWindowCaption: WM_GETTEXT returned 'Razhod.xls'
07-09-3917 22:35:29.204> GetWindowCaption: WM_GETTEXT returned 'Razhod.xls'
07-09-3917 22:35:29.362> GetWindowCaption: WM_GETTEXT returned 'Razhod.xls'
07-09-3917 22:35:29.518> GetWindowCaption: WM_GETTEXT returned 'Razhod.xls'
07-09-3917 22:35:29.673> GetWindowCaption: WM_GETTEXT returned 'Razhod.xls'
07-09-3917 22:35:29.845> GetWindowCaption: WM_GETTEXT returned 'Razhod.xls'
07-09-3917 22:35:29.995> GetWindowCaption: WM_GETTEXT returned 'Razhod.xls'
07-09-3917 22:35:30.242> GetWindowCaption: WM_GETTEXT returned 'Razhod.xls'
07-09-3917 22:35:30.414> MouseHookLLProc: MouseHookData: Msg=0x0204 (WM_RBUTTONDOWN), X=1142, Y=385, Data=0x00000000, Flags=0x00000000, Time=693317203, Info=0x0, Ptr=0x5D0EE7, Layer=0
07-09-3917 22:35:30.414> Translating Right Button Down Key state 0x10: Action 128 [Button Chording]
07-09-3917 22:35:30.414> Setting global chord
07-09-3917 22:35:30.414> MouseHookLLProc: Removing message 0x0204 from mouse hook queue as we have overridden it.
07-09-3917 22:35:30.477> MouseHookLLProc: MouseHookData: Msg=0x0205 (WM_RBUTTONUP), X=1142, Y=385, Data=0x00000000, Flags=0x00000000, Time=693317265, Info=0x0, Ptr=0x5D0EE7, Layer=0
07-09-3917 22:35:30.477> StopQTTimer: DeleteTimerQueueTimer 4 (0x87eb82b0)
07-09-3917 22:35:30.477> Chording: Release original chord button
07-09-3917 22:35:30.477> Translating Right Button Up Key state 0x10: Action 128 [Button Chording]
07-09-3917 22:35:30.477> Translating Right Button Down Key state 0x10: Action 128 (Button Chording) becomes Action 40 [** No Change (Don't intercept) **]
07-09-3917 22:35:30.477> SendInput::SendMouse: Queue mouse button='Right', Action='Down', Point=1142,385, MouseHookPtr=0x5D0EE7
07-09-3917 22:35:30.477> Translating Right Button Up Key state 0x10: Action 128 (Button Chording) becomes Action 40 [** No Change (Don't intercept) **]
07-09-3917 22:35:30.477> SendInput::SendMouse: Queue mouse button='Right', Action='Up', Point=1142,385, MouseHookPtr=0x5D0EE7
07-09-3917 22:35:30.477> ProcessButton: Chord active; Releasing global chord
07-09-3917 22:35:30.477> MouseHookLLProc: Removing message 0x0205 from mouse hook queue as we have overridden it.
07-09-3917 22:35:30.477> MouseHookLLProc: MouseHookData: Msg=0x0204 (WM_RBUTTONDOWN) Injected, X=1142, Y=385, Data=0x00000000, Flags=0x00000001, Time=693317265, Info=0x5D0EE7, Ptr=0x5D0EE7, Layer=0
07-09-3917 22:35:30.477> MouseHookLLProc: Ignoring mouse message injected by X-Mouse Button Control
07-09-3917 22:35:30.477> MouseHookLLProc: Passing original mouse message 00000204 through....
07-09-3917 22:35:30.477> MouseHookLLProc: MouseHookData: Msg=0x0205 (WM_RBUTTONUP) Injected, X=1142, Y=385, Data=0x00000000, Flags=0x00000001, Time=693317265, Info=0x5D0EE7, Ptr=0x5D0EE7, Layer=0
07-09-3917 22:35:30.477> MouseHookLLProc: Ignoring mouse message injected by X-Mouse Button Control
07-09-3917 22:35:30.477> MouseHookLLProc: Passing original mouse message 00000205 through....
07-09-3917 22:35:30.555> GetWindowCaption: WM_GETTEXT returned 'Razhod.xls'
07-09-3917 22:35:48.052> KeyHookLLProc: Resetting mouse cursor speed to 10 after 'Slowdown by key'
07-09-3917 22:35:48.161> KeyHookLLProc: Resetting mouse cursor speed to 10 after 'Slowdown by key'
07-09-3917 22:35:48.161> Received global hotkey: 8
<<<<<<<<<<<<<<<<<<<<07-09-3917 22:35:48.161> Disabling extra debug logging.<<<<<<<<<<<<<<<<<<<<

07-09-3917 22:36:20.199> Removing any active XMBCHook Timers...
07-09-3917 22:36:20.199> CSendInput: Exiting SendInput thread.
07-09-3917 22:36:20.214> Hook thread exited with error code 0.
07-09-3917 22:36:20.214> Timer thread exited with error code 0.
07-09-3917 22:36:20.214> SetHotkeys installed 3 global hotkeys...
07-09-3917 22:36:24.831> Loaded 14 application specific profiles (7 normal and 7 custom window).
07-09-3917 22:36:24.831> Using keyboard language 0x04090409
07-09-3917 22:36:24.831> SetHotkeys installed 8 global hotkeys...
07-09-3917 22:42:22.901> CMyMessageWnd::OnSetup   -   Opening setup dialog.
07-09-3917 22:42:22.932> Loaded 14 application specific profiles (7 normal and 7 custom window).
07-09-3917 22:42:53.495> CMyMessageWnd::OnSetup   -   Setup dialog closed.
07-09-3917 22:42:53.527> Loaded 14 application specific profiles (7 normal and 7 custom window).
07-09-3917 22:42:53.527> SetHotkeys installed 8 global hotkeys...
07-09-3917 22:42:58.522> You are using the latest available version of X-Mouse Button Control.
I suppose it has something to do with my excel profile so here it is:
Excel.xmbcs

Also my mouse often skips a click (but that is an old problem and this has never happened before) and maybe it is possible that it sometimes sends only one signal (only up or only down) which could be the root cause I think :?
I wonder if someone else has ever reported something similar :roll:

Thanks
Iliya
You do not have the required permissions to view the files attached to this post.
HAMA Mirano
Windows 8.1 x64, Intel i5-3230M @ 2.60GHz, 4GB

User avatar
phil
Site Admin
Posts: 5718
Joined: Sun Apr 06, 2003 11:12 pm

Re: Strange issue...

Post by phil » Fri Sep 08, 2017 7:44 am

Hi Iliya,

This does indeed sound odd - but the log you pasted does not appear to show any problem, that is, there are two left clicks, (a left down followed by up) which appear to be passing the message through (as you would expect with no change) and a right down (cording) followed by an up (cancel chord) which also, you would expect.

Unfortunately this means either the log isn't good enough, or something very strange and unknown is occurring, like the hook not receiving messages... Its also odd that disabling XMBC via a hotkey makes no difference, but disabling it via the context menu does...

My only thoughts right now, is are the coordinates correct, or is somehow, the mouse button coordinates wrong, causing windows to think the click is outside the window area (unfortunately the window areas are not logged) but I suspect if that were the case, XMBC wont be the cause? what DPI are you using and is this changing at any point (like for example, when I remote desktop to my desktop (100% 96 dpi) from my laptop (125% 120dpi) the desktop DPI gets adjusted by RDP and it takes a few seconds to sort itself out (graphically and mouse clicks).

Thanks,
Phil
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-9600k, Asus Z390-ROG, 16GB DDR4,
nVidia GeForce GTX 970, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

User avatar
injtsvetkov
Fanatic
Posts: 257
Joined: Mon Jun 06, 2016 8:51 am

Re: Strange issue...

Post by injtsvetkov » Mon Sep 11, 2017 12:03 pm

Hi Phil,
I don't change the DPI, it seemed to me like the clicks has been sent to a different process and not the one under the cursor. I don't know what's the possibility of this happening but if you say that the clicks are there (in the log) so most probably it's that or as you suspected the hook not receiving the messages which is too unclear to me and I don't know what to think. Just wondering if when I click into a focused window it gets unfocused but nothing else happens doesn't that mean that the hook has received the message but after that it went somewhere else instead of the right window/process. Back then I L-clicked and R-clicked all over the desktop but nothing happened and I suppose if merely the coordinates were wrong some clicks would still work. Surprisingly the R-click on the tray icon worked and I disabled XMBC but the second time no clicks worked at all that's why I couldn't use the system tray icon and had to disable XMBC via the hotkey. Now the second time the excel window was active (maximized) and the mouse was stuck (LMB down) in it but the first time it was minimized and I wonder if that could have anything to do with it :roll:. It somehow looked like the excel profile is still active even after minimizing excel, but unfortunately I didn't notice what profile was active in the profile list in the settings window :(. Next time I should check that. As far as I can see the log does not indicate which profile was active when the clicks were sent. Do you have any suggestions about what can I try when this happens again? It would be nice if there is a way to rule out some of the possibilities.

Thanks!
Iliya
HAMA Mirano
Windows 8.1 x64, Intel i5-3230M @ 2.60GHz, 4GB

Post Reply