I have upgraded the board - please let me know if you have any problems

disable xmbc requiring admin elevation

x64 Replacement/Alternative to Microsoft's IntelliMouse application.
Post Reply
tsreyb
New User
Posts: 2
Joined: Fri Mar 31, 2017 5:00 pm

disable xmbc requiring admin elevation

Post by tsreyb » Fri Mar 31, 2017 6:00 pm

I'm using xmbc 2.15 with Win 7 in an enterprise environment.

When I logon I am presented with a pop-up window requesting my password to authorize execution of xmbc with administrative privileges.

As I understand it, I only need xmbc to run in elevated mode if I want xmbc to control elevated applications. Since I do not have that desire, I'd like to *not* run xmbc in elevated mode.

However, I cannot see how to disable admin elevation.

I have looked through "Setup > Options", "Setup > Settings > General", and "Setup > Settings > Advanced", etc. I didn't find anything that would control whether it runs with admin elevation or not.

[later] hmmm .... if I reinstall, but only as myself (so it is no longer installed in "c:\program files", that is probably the solution, correct? I will try this out and report back...

[still later] ugghh ... still requires admin elevation at logon. This was after I reinstalled. But there was no choice to install for everyone or 'just this user'. Instead, I installed with a destination folder under my home directory ("c:\Users\ABC\XMouseButtonControl"). During the install it mentioned that my settings would be stored in my appdata directory, and I did not modify that setting. Restarted my pc, logged on as me, and was promptly presented with the familiar pop-up window requiring admin elevation for XMBC

Is it possible to run xmbc as a non-elevated user?

(I have a screen shot of the pop-up window, but as a new user I cannot upload it here)

User avatar
phil
Site Admin
Posts: 5092
Joined: Sun Apr 06, 2003 11:12 pm

Re: disable xmbc requiring admin elevation

Post by phil » Fri Mar 31, 2017 7:00 pm

XMBC should not require elevation to run - however it runs as a UI Accessibility tool which i suppose your enterprise may have adjusted the settings for, in effect requiring admin access, but that is not the normal behaviour.

There is no setting in XMBC as it does not normally need to be elevated to run as a UI accessibility tool, nor can such a setting be changed as its baked into the compiled/embedded application manifest file!

You could try the portable download as that does not even run as a UI accessibility tool (it cant if its not installed under \programfiles)

PS, what version of XMBC? Its always possible there is a bug in an older version but I'm happily running 2.15 without admin access on my test machines.

Thanks,
Phil
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-6600k, Asus 170-A, 16GB DDR4,
nVidia GeForce GTX 970, 2xEvo 850 (RAID 0), 2x2TB WD Black (RAID1)

tsreyb
New User
Posts: 2
Joined: Fri Mar 31, 2017 5:00 pm

Re: disable xmbc requiring admin elevation

Post by tsreyb » Sun Apr 02, 2017 3:10 pm

Per your suggestion I installed the portable version (& uninstalled the regular version). This has resolved my problem and I'm no longer required to authorize admin elevation.

I suspect, as you do, my IT has adjusted the settings. We run a pretty tight ship at this workplace.

(btw since you asked, I am/was running xmbc v2.15)

thanks for the quick reply!

Another happy customer,
-Bob

User avatar
phil
Site Admin
Posts: 5092
Joined: Sun Apr 06, 2003 11:12 pm

Re: disable xmbc requiring admin elevation

Post by phil » Sun Apr 02, 2017 4:15 pm

Thanks for letting me know that the portable version resolved this particular issue.
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-6600k, Asus 170-A, 16GB DDR4,
nVidia GeForce GTX 970, 2xEvo 850 (RAID 0), 2x2TB WD Black (RAID1)

Post Reply

Who is online

Users browsing this forum: Bing [Bot] and 3 guests