scrolling in add/remove ("programs & features") windows error

x64 Replacement/Alternative to Microsoft's IntelliMouse application.
Kylde
Dedicated
Posts: 48
Joined: Thu Dec 23, 2010 4:20 pm

Re: scrolling in add/remove ("programs & features") windows error

Post by Kylde » Fri Apr 21, 2017 9:00 pm

phil wrote:OK, please can you explain when it goes back to the text without (desktop). Is it when you are editing, or just it just randomly go back?

It might be useful to turn on debug logging and try and reproduce it - it might give me some more idea of the internal paths its taking.

Thanks,
Phil
OK I've JUST had it happen again, it seems to be when Explorer crashes & re-runs. I had already enabled debug logging, but it turned itself off or something 4 days ago. Once it happens, the profile window looks like this:

Image

and the explorer profile shows as:

Image


but xmouse (2.16 beta 12) simply fails to respond to mousewheel rotate/middle-click until I use the "target" arrow to select desktop, and then the wheel/middle-click work fine again

Kylde
Dedicated
Posts: 48
Joined: Thu Dec 23, 2010 4:20 pm

Re: scrolling in add/remove ("programs & features") windows error

Post by Kylde » Fri Apr 21, 2017 9:08 pm

phil wrote:OK, please can you explain when it goes back to the text without (desktop). Is it when you are editing, or just it just randomly go back?

It might be useful to turn on debug logging and try and reproduce it - it might give me some more idea of the internal paths its taking.

Thanks,
Phil
OK I've JUST had it happen again, it seems to be when Explorer crashes & re-runs. I had already enabled debug logging, but it turned itself off or something 4 days ago. Once it happens, the profile window looks like this:

Image

and the explorer profile shows as:

Image


but xmouse (2.16 beta 12) simply fails to respond to mousewheel rotate/middle-click until I use the "target" arrow to select desktop, and then the wheel/middle-click work fine again

User avatar
phil
Site Admin
Posts: 5199
Joined: Sun Apr 06, 2003 11:12 pm

Re: scrolling in add/remove ("programs & features") windows error

Post by phil » Mon Apr 24, 2017 7:50 am

Ah, if explorer )the desktop) crashes, then the window handle will change so it might be that - I dont have explorer crash very often but we can reproduce by killing explorer in task manager and see if that is the cause -if so, I can probably fix that. PS rather than remaking the profile, does closing XMBC and re-opening it also fix it?
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-6600k, Asus 170-A, 16GB DDR4,
nVidia GeForce GTX 970, 2xEvo 850 (RAID 0), 2x2TB WD Black (RAID1)

Kylde
Dedicated
Posts: 48
Joined: Thu Dec 23, 2010 4:20 pm

Re: scrolling in add/remove ("programs & features") windows error

Post by Kylde » Mon Apr 24, 2017 7:33 pm

phil wrote: PS rather than remaking the profile, does closing XMBC and re-opening it also fix it?
Never thought of that, I'll try to recreate the crash & restart xmbc :)

User avatar
phil
Site Admin
Posts: 5199
Joined: Sun Apr 06, 2003 11:12 pm

Re: scrolling in add/remove ("programs & features") windows error

Post by phil » Mon Apr 24, 2017 8:11 pm

OK, I think I managed to reproduce it... Although on Windows 10, it does eventually start working again after a few seconds.... I guess maybe Win 7 handles the restart of explorer differently (or crashing is different from killing explorer.exe and restarting it manually). I will have to do some testing on there to see if my "fix" works before I push the next beta out.
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-6600k, Asus 170-A, 16GB DDR4,
nVidia GeForce GTX 970, 2xEvo 850 (RAID 0), 2x2TB WD Black (RAID1)

Kylde
Dedicated
Posts: 48
Joined: Thu Dec 23, 2010 4:20 pm

Re: scrolling in add/remove ("programs & features") windows error

Post by Kylde » Tue Apr 25, 2017 11:55 am

phil wrote:OK, I think I managed to reproduce it... Although on Windows 10, it does eventually start working again after a few seconds.... I guess maybe Win 7 handles the restart of explorer differently (or crashing is different from killing explorer.exe and restarting it manually).
These issues are on Windows 10 here, Version 1703 (OS Build 15063.138), Windows Home 64-bit, the "Creators Update"

User avatar
phil
Site Admin
Posts: 5199
Joined: Sun Apr 06, 2003 11:12 pm

Re: scrolling in add/remove ("programs & features") windows error

Post by phil » Tue Apr 25, 2017 6:38 pm

Oh - OK sorry I thought you were on 7 :)
I haven't got the creators update yet on my desktop - perhaps I should wait for that before confirming.

Out of interest, how are you crashing explorer - it seems like my version does not crash :)
Whilst I think Ive fixed it, I wont know for sure - I suppose the best thing to do would be to push out beta 15 for you to try (will do that shortly).

Thanks,
Phil
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-6600k, Asus 170-A, 16GB DDR4,
nVidia GeForce GTX 970, 2xEvo 850 (RAID 0), 2x2TB WD Black (RAID1)

Kylde
Dedicated
Posts: 48
Joined: Thu Dec 23, 2010 4:20 pm

Re: scrolling in add/remove ("programs & features") windows error

Post by Kylde » Tue Apr 25, 2017 6:48 pm

phil wrote:Oh - OK sorry I thought you were on 7 :) Out of interest, how are you crashing explorer - it seems like my version does not crash :)
By killing all instances of explorer.exe in taskman :) I used to be on 7, last time I created a thread (& I still prefer it over 10, but times move on)

User avatar
phil
Site Admin
Posts: 5199
Joined: Sun Apr 06, 2003 11:12 pm

Re: scrolling in add/remove ("programs & features") windows error

Post by phil » Tue Apr 25, 2017 6:49 pm

Please try 2.16 Beta 15 (just published).
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-6600k, Asus 170-A, 16GB DDR4,
nVidia GeForce GTX 970, 2xEvo 850 (RAID 0), 2x2TB WD Black (RAID1)

Kylde
Dedicated
Posts: 48
Joined: Thu Dec 23, 2010 4:20 pm

Re: scrolling in add/remove ("programs & features") windows error

Post by Kylde » Mon May 01, 2017 3:05 am

nothing to report here on the latest beta, which is good, I've not been able to force xmouse to glitch at all. Man I've just glanced at my profile & realised I've been using this software for AT LEAST 7 years, kudos to you Phil, many commercial concerns don't maintain their product for this long

User avatar
phil
Site Admin
Posts: 5199
Joined: Sun Apr 06, 2003 11:12 pm

Re: scrolling in add/remove ("programs & features") windows error

Post by phil » Mon May 01, 2017 10:25 am

That's a relief -my fix appears to be working :).

As for 7 years - yes that's quite a long time. One of the benefits of XMBC in that respect is that it is a hobby project and something that I enjoy doing and use myself - and as long as that continues, XMBC will continue :).

Regards,
Phil
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-6600k, Asus 170-A, 16GB DDR4,
nVidia GeForce GTX 970, 2xEvo 850 (RAID 0), 2x2TB WD Black (RAID1)

Kylde
Dedicated
Posts: 48
Joined: Thu Dec 23, 2010 4:20 pm

Re: scrolling in add/remove ("programs & features") windows error

Post by Kylde » Tue May 02, 2017 12:46 am

phil wrote:As for 7 years - yes that's quite a long time. One of the benefits of XMBC in that respect is that it is a hobby project and something that I enjoy doing and use myself - and as long as that continues, XMBC will continue :).
Image

User avatar
phil
Site Admin
Posts: 5199
Joined: Sun Apr 06, 2003 11:12 pm

Re: scrolling in add/remove ("programs & features") windows error

Post by phil » Tue May 02, 2017 12:48 am

LOL :)
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-6600k, Asus 170-A, 16GB DDR4,
nVidia GeForce GTX 970, 2xEvo 850 (RAID 0), 2x2TB WD Black (RAID1)

Kylde
Dedicated
Posts: 48
Joined: Thu Dec 23, 2010 4:20 pm

Re: scrolling in add/remove ("programs & features") windows error

Post by Kylde » Sat May 13, 2017 2:41 pm

phil wrote:
Tue Apr 25, 2017 6:38 pm
Out of interest, how are you crashing explorer
Just found this tip that I never knew for restarting explorer

http://winaero.com/blog/how-to-properly ... n-windows/

(SHIFT+CTRL & right-click taskbar, or SHIFT+CTRL & right-click the Start menu). Who knew :lol: ?

User avatar
phil
Site Admin
Posts: 5199
Joined: Sun Apr 06, 2003 11:12 pm

Re: scrolling in add/remove ("programs & features") windows error

Post by phil » Sat May 13, 2017 2:45 pm

That is news to me too - may come in handy - thanks!
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-6600k, Asus 170-A, 16GB DDR4,
nVidia GeForce GTX 970, 2xEvo 850 (RAID 0), 2x2TB WD Black (RAID1)

Post Reply

Who is online

Users browsing this forum: No registered users and 10 guests