X-Mouse resets mouse speed to 0

x64 Replacement/Alternative to Microsoft's IntelliMouse application.
Forum rules
Please read the forum rules before posting for the first time.
The more information you can provide, the quicker and more accurately someone can help.
Post Reply
bibbis
New User
Posts: 8
Joined: Fri Sep 30, 2011 6:18 pm

X-Mouse resets mouse speed to 0

Post by bibbis » Sat Mar 18, 2017 8:55 am

As soon as I activate a profile in X-Mouse, the mouse speed is set to 0.

I downloaded version 2.15 today and I'm on Windows 10.

X-Mouse seems to think that my system settings for cursor speed is 0.
Because if I choose to NOT "Override Mouse Speed", then the speed is immediately turned down to the lowest possible as soon as I activate the X-Mouse profile.

Steps to re-create the issue:
1. I open the mouse settings in windows, and set the cursor speed:
http://imgur.com/a/9hHJa

2. I launch X-Mouse, and the speed is immediately set to the lowest possible.
I double-check in the settings that Override Mouse Speed is still disabled for the default profile:
http://imgur.com/a/HjNjy

3. I open mouse properties again and see that X-Mouse has indeed lowered the speed to 0:
http://imgur.com/a/5h7nL

User avatar
phil
Site Admin
Posts: 5528
Joined: Sun Apr 06, 2003 11:12 pm

Re: X-Mouse resets mouse speed to 0

Post by phil » Sun Mar 19, 2017 5:01 pm

Thanks for letting me know - I have seen this problem too so I will look into it and fix it in the next beta.

EDIT: What is the pointer speed set to in the general settings tab? If you set it there, it *should* remeber the setting from then on (and I will still try and fix it!)

Thanks,
Phil
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-6600k, Asus 170-A, 16GB DDR4,
nVidia GeForce GTX 970, 2xEvo 850 (RAID 0), 2x2TB WD Black (RAID1)

User avatar
phil
Site Admin
Posts: 5528
Joined: Sun Apr 06, 2003 11:12 pm

Re: X-Mouse resets mouse speed to 0

Post by phil » Sun Mar 19, 2017 6:46 pm

PS, if you had looked, this was reported a couple of days ago here too...
https://forums.highrez.co.uk/viewtopic. ... 547#p13154
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-6600k, Asus 170-A, 16GB DDR4,
nVidia GeForce GTX 970, 2xEvo 850 (RAID 0), 2x2TB WD Black (RAID1)

bibbis
New User
Posts: 8
Joined: Fri Sep 30, 2011 6:18 pm

Re: X-Mouse resets mouse speed to 0

Post by bibbis » Sun Mar 19, 2017 8:53 pm

phil wrote:Thanks for letting me know - I have seen this problem too so I will look into it and fix it in the next beta.

EDIT: What is the pointer speed set to in the general settings tab? If you set it there, it *should* remeber the setting from then on (and I will still try and fix it!)

Thanks,
Phil
Hi Phil,
Thanks for responding.
I looked in the general settings and there it is indeed set to 0.
Changing this setting works as a temp fix for now.

Yes I searched in the forum at first, but since that thread has the title "Mouse Wheel Pointer Speed" I didn't click it, because I don't have issues with the mouse wheel :P

User avatar
phil
Site Admin
Posts: 5528
Joined: Sun Apr 06, 2003 11:12 pm

Re: X-Mouse resets mouse speed to 0

Post by phil » Mon Mar 20, 2017 8:37 am

Sure, a bad title :)
Ive fixed the problem in 2.16 beta 4 (but if you have saved your settings in 2.15, the problem will persist - i.e. you have to go change it in general settings. It wont happen again from a fresh install!

Thanks,
Phil
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-6600k, Asus 170-A, 16GB DDR4,
nVidia GeForce GTX 970, 2xEvo 850 (RAID 0), 2x2TB WD Black (RAID1)

bibbis
New User
Posts: 8
Joined: Fri Sep 30, 2011 6:18 pm

Re: X-Mouse resets mouse speed to 0

Post by bibbis » Wed Mar 22, 2017 1:17 pm

phil wrote:Sure, a bad title :)
Ive fixed the problem in 2.16 beta 4 (but if you have saved your settings in 2.15, the problem will persist - i.e. you have to go change it in general settings. It wont happen again from a fresh install!

Thanks,
Phil
Thank you for taking care of it so fast :)

al5em
New User
Posts: 2
Joined: Wed Dec 13, 2017 12:36 am

Re: X-Mouse resets mouse speed to 0

Post by al5em » Wed Dec 13, 2017 12:43 am

Hi,

I have a similar problem. Whenever I open X-Mouse, or boot Windows, X-Mouse resets the mouse speed. I set it to 3, but it is always set back to 5 and I have to revert it manually everytime. I tried all kinds of settings in the "override mouse speed" section but nothing helps. I don't use any additional mouse software.

demonstration: https://www.youtube.com/watch?v=_AM--85Ls2c

User avatar
phil
Site Admin
Posts: 5528
Joined: Sun Apr 06, 2003 11:12 pm

Re: X-Mouse resets mouse speed to 0

Post by phil » Wed Dec 13, 2017 12:47 am

Forget the options tab, thats not enabled anyway - what does it say on the general settings "Mouse speed"?
And if you set it to 3 in there, does it stick?

EDIT: There was a fix in 2.17 beta 4 to this area so you might want to try the latest 2.17 beta and check that it now works!
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-6600k, Asus 170-A, 16GB DDR4,
nVidia GeForce GTX 970, 2xEvo 850 (RAID 0), 2x2TB WD Black (RAID1)

al5em
New User
Posts: 2
Joined: Wed Dec 13, 2017 12:36 am

Re: X-Mouse resets mouse speed to 0

Post by al5em » Wed Dec 13, 2017 12:50 am

thanks for the quick reply. yeah it took me a while to find the global settings button in the left bottom corner.

Post Reply