Page 16 of 19

Re: XMBC 2.16 Beta

Posted: Mon May 08, 2017 3:05 am
by JTB3
phil wrote:
Sun May 07, 2017 9:05 pm
Oh typical - I bet it's because chrome 'tabs' are actually run out of process (separate exe's)... I'll try and take a look tomorrow!
Thx Phil, Looking forward! :)

Re: XMBC 2.16 Beta

Posted: Mon May 08, 2017 4:45 am
by JTB3
maxoku wrote:
Mon May 08, 2017 1:57 am
While the activate tag is working so great, maybe you'd consider to put it in the ui in the future. So users won't have to use simulated keys everytime to use it, but it would work with some options from the drop list as well like paste for example. :D
I concur with maxoku. While totally diggin' the new {ACTIVATE} tag, I've had to come up with several creative workarounds to compensate for not being able to utilize any of the nice preconfigured XMBC drop-down list commands (unavailable as simkey tags) - like 'Close' which behaves differently than ALT+F4 in some windows, and 'Minimize' (which I worked around by using the {ACTIVATE}{LWIN}{DOWN} tag combo).

In addition to keeping the new awesome {ACTIVATE} simkey tag, here are a couple of ideas that could potentially solve the above limitations down the line:

1) Add 'SimKey Tags' for the missing/relevant UI drop-down 'commands' - so they can be integrated along with other custom SimKeys, including the new {ACTIVATE} tag [This might be the easiest 1st-step, flexible option to code/program].

AND/OR
2) Add 'Activate' [on downpress] checkboxes in the layer UI next to each of the 5 'Buttons' - This would allow XMBC users to (optionally) mimic the normal Windows activation behavior when intercepting any of the standard 5 mouse buttons.

[mockup image proposal]
XMBC - Activate UI Button Proposal.png
-
Both of these ideas (implemented either individually or combined) are 'nice-to-have' upgrades, and I certainly appreciate how valuable your time is Phil, and all the great work you've done thus far in providing us the {Activate} tag! :)

Penny for your thoughts... -JT

Re: XMBC 2.16 Beta

Posted: Mon May 08, 2017 7:47 am
by phil
maxoku wrote:
Mon May 08, 2017 1:57 am
In English it's working fine, the problem is in other languages. :?
I know - thats because in English it does not wrap onto 2 lines - its only a problem when it wraps -and I cant figure out why.
maxoku wrote:
Mon May 08, 2017 1:57 am
While the activate tag is working so great, maybe you'd consider to put it in the ui in the future. So users won't have to use simulated keys everytime to use it, but it would work with some options from the drop list as well like paste for example. :D
I dont think I want to add it to the UI - it will be messy and there isn't much room in there - it will have to be at the same time as another UI ovrhaul if that happens[/quote]
maxoku wrote:
Mon May 08, 2017 1:57 am
Well you fixed the main issue with the that button, but there are still two minor ones. First is that there is nothing when I hover it. It should look like unpressed (convex) button then :P . The second one is that when I press it it looks like it was pressed double time (double deep). Also if I press the button (hold it) and take the cursor out from the button it stays pressed, but one time. :lol:
It's not a big of a deal, but maybe one day you'll have some extra time, will be bored and in the super great mood and look into it. :P
OK I'll bear that in mind and add it to the list but probably not fix before 2.16 is released.
maxoku wrote:
Mon May 08, 2017 1:57 am
I've reported that before but you probably missed it. In Modifier keys settings Other modifiers the access key for Slow down cursor is make it go focus to Enable modifier keys tickbox, but without ticking it. Before you ask there isn't any access key in English, but I added them in Polish. :lol:
Maybe there is no access key in the English template because it didn't work :) I haven't looked at that one - will add i to the list but dont expect miracles!

Re: XMBC 2.16 Beta

Posted: Mon May 08, 2017 11:42 am
by BriHecato
The main body of a Chrome 'App' window is NOT responding to the {Activate} tag - But the title-bar area IS responding normally.
Probably the same append to Vivaldi - since it's the same core (chromium), that's why my default chording for printing doesn't work if i have only one tab, as well as copy/paste with 4th/5th button also doesn't work in omnibox adress bar (but default action of 4th and 5th button - backward/forward is blocked).

Glad to hear that Phil look into it :)
phil wrote: I dont think I want to add it to the UI - it will be messy and there isn't much room in there - it will have to be at the same time as another UI ovrhaul if that happens
In settings along the checkbox

Code: Select all

"Separate explorer profile from desktop profile"
You can add another

Code: Select all

"Force activation while mouse over"
(or this can be not global setting but profile-wide setting, that one can apply it to selected profiles)

Re: XMBC 2.16 Beta

Posted: Mon May 08, 2017 4:43 pm
by phil
BriHecato wrote:
Mon May 08, 2017 11:42 am
The main body of a Chrome 'App' window is NOT responding to the {Activate} tag - But the title-bar area IS responding normally.
Probably the same append to Vivaldi - since it's the same core (chromium), that's why my default chording for printing doesn't work if i have only one tab, as well as copy/paste with 4th/5th button also doesn't work in omnibox adress bar (but default action of 4th and 5th button - backward/forward is blocked).

Glad to hear that Phil look into it :)
I doubt its the same - but we shall see.
The problem with Chrome is that chrome itself isn't responding properly to the activate tag over certain parts of the window. Unlikely to be the same problem for other commands.
BriHecato wrote:
Mon May 08, 2017 11:42 am
phil wrote: I dont think I want to add it to the UI - it will be messy and there isn't much room in there - it will have to be at the same time as another UI ovrhaul if that happens
In settings along the checkbox

Code: Select all

"Separate explorer profile from desktop profile"
You can add another

Code: Select all

"Force activation while mouse over"
(or this can be not global setting but profile-wide setting, that one can apply it to selected profiles)
What "Separate explorer profile ..." option - I don't recall there being one and I don't intend to add one!

And anyway, they were talking about an option next to the button dropdown (for each button). (see JTB3's screenshot above) and I don't intend doing that either in 2.16! As I said to Makoku, I don't want to make any drastic GUI changes (and that is a big code change - even if it looks small!).

Re: XMBC 2.16 Beta

Posted: Mon May 08, 2017 6:35 pm
by phil
OK the problem in chrome wit {ACTIVATE} as described in JTB3's last video also occurs in Vivaldi - that is, the new {activate} tag does not activate the window properly - but its not clear if thats what you mean when you say
BriHecato wrote:
Mon May 08, 2017 11:42 am
Probably the same append to Vivaldi - since it's the same core (chromium), that's why my default chording for printing doesn't work if i have only one tab, as well as copy/paste with 4th/5th button also doesn't work in omnibox adress bar (but default action of 4th and 5th button - backward/forward is blocked).
As in I dont think your using the new {activate} tag so I dont think that's the same problem.

I just installed vivaldi so I can test - I have got the activate working properly with it (and chrome). If there are other issues, you need to report them properly please - give more detail and steps to reproduce.

I'll push out beta 19 (when will this end!) shortly!

Re: XMBC 2.16 Beta

Posted: Mon May 08, 2017 6:59 pm
by phil
Here is 2.16 Beta 19.

If you have check for beta versions enabled, you should get notified of a new version and prompted to update in the next day or so. This is the most efficient method (bandwidth wise) as the updates are only a fraction of the size of the full install. Otherwise, you can get the full installation beta HERE. Note that this link will always get you the latest beta version!

Changes since v2.16 Beta 18:
  • #488 - Fixed issue with the new {ACTIVATE} tag with chrome/vivaldi windows.
There are no translation/language file updates in 2.16 Beta 19.

Any problems, PM me a copy of the log file (or post a snippet in a code block here).

Thanks,
Phil

Re: XMBC 2.16 Beta

Posted: Mon May 08, 2017 7:48 pm
by JTB3
phil wrote:
Mon May 08, 2017 6:59 pm
Here is 2.16 Beta 19...
Changes since v2.16 Beta 18:
  • #488 - Fixed issue with the new {ACTIVATE} tag with chrome/vivaldi windows.
Thanks, Phil
Awesome work Phil! All my testing so far has worked flawlessly! :cheers:
Many thanks! We're another step closer to XMBC nirvana! :lol:
-JT

P.S. The auto update flyout+downloader also worked great (on both of my computers) without issue. :)

Re: XMBC 2.16 Beta

Posted: Mon May 08, 2017 7:53 pm
by maxoku
phil wrote:
Mon May 08, 2017 7:47 am
maxoku wrote:
Mon May 08, 2017 1:57 am
In English it's working fine, the problem is in other languages. :?
I know - that's because in English it does not wrap onto 2 lines - its only a problem when it wraps -and I cant figure out why.
Well, then I will need to mess with the translation. :|
phil wrote:
Mon May 08, 2017 7:47 am
maxoku wrote:
Mon May 08, 2017 1:57 am
While the activate tag is working so great, maybe you'd consider to put it in the ui in the future. So users won't have to use simulated keys everytime to use it, but it would work with some options from the drop list as well like paste for example. :D
I don't think I want to add it to the UI - it will be messy and there isn't much room in there - it will have to be at the same time as another UI overhaul if that happens
Well a tick boxes (without text) on left from the drop boxes would fit I think. Well I asked to consider that in the future, I hope you will. :P
phil wrote:
Mon May 08, 2017 7:47 am
OK I'll bear that in mind and add it to the list but probably not fix before 2.16 is released.
Oki, thanx, I'll bear waiting. :lol:

Re: XMBC 2.16 Beta

Posted: Mon May 08, 2017 8:04 pm
by phil
maxoku wrote:
Mon May 08, 2017 7:53 pm
Well, then I will need to mess with the translation. :|
You can try but its not really a show stopper (and would have been in multiple previous versions) so its not all that important (in my opinion). Perfect is a never reachable goal :)

Re: XMBC 2.16 Beta

Posted: Mon May 08, 2017 8:22 pm
by maxoku
phil wrote:
Mon May 08, 2017 8:04 pm
maxoku wrote:
Mon May 08, 2017 7:53 pm
Well, then I will need to mess with the translation. :|
You can try but its not really a how stopper (and would have been in multiple previous versions) so its not all that important (in my opinion). Perfect is a never reachable goal :)
Well I meant that I will make it in one line or remove the accelerator, at least with the second one for rate that the letter is being crossed. Or you could move that ms boxes more to right that there would be more space for text. :P

Re: XMBC 2.16 Beta

Posted: Tue May 09, 2017 11:32 am
by injtsvetkov
phil wrote:
Mon May 08, 2017 8:04 pm
Perfect is a never reachable goal :)
Never say Never :P

Re: XMBC 2.16 Beta

Posted: Tue May 09, 2017 12:24 pm
by BriHecato
phil wrote:
Mon May 08, 2017 6:35 pm
OK the problem in chrome wit {ACTIVATE} as described in JTB3's last video also occurs in Vivaldi - that is, the new {activate} tag does not activate the window properly - but its not clear if thats what you mean when you say
BriHecato wrote:
Mon May 08, 2017 11:42 am
Probably the same append to Vivaldi - since it's the same core (chromium), that's why my default chording for printing doesn't work if i have only one tab, as well as copy/paste with 4th/5th button also doesn't work in omnibox adress bar (but default action of 4th and 5th button - backward/forward is blocked).
As in I dont think your using the new {activate} tag so I dont think that's the same problem.

I just installed vivaldi so I can test - I have got the activate working properly with it (and chrome). If there are other issues, you need to report them properly please - give more detail and steps to reproduce.

I'll push out beta 19 (when will this end!) shortly!
Yes it's not about {ACTIVATE} tag but with some kind of global strange behaviour in (i think) chromium based browsers (but i may be wrong, since i didn't test any opera).
Also i do not report some behaviours as issues since i'm almost sure it's not XMBC fault but the other app.

Re: XMBC 2.16 Beta

Posted: Tue May 09, 2017 5:01 pm
by phil
BriHecato wrote:
Tue May 09, 2017 12:24 pm
Yes it's not about {ACTIVATE} tag but with some kind of global strange behaviour in (i think) chromium based browsers (but i may be wrong, since i didn't test any opera).
Also i do not report some behaviours as issues since i'm almost sure it's not XMBC fault but the other app.
OK - Yes I suspect you are right - although you might like to try your commands (simkeys) with {ACTIVATE} before them now and see if it helps/makes any difference.

Thanks,
Phil

Re: XMBC 2.16 Beta

Posted: Tue May 16, 2017 7:04 pm
by phil
So its been over a week now - and nothing new has crept out - do you think I should release 2.16 as is?
Of course, its only upon release that I will really know :)