XMBC 2.16 Beta

x64 Replacement/Alternative to Microsoft's IntelliMouse application.
Forum rules
Please read the forum rules before posting for the first time.
The more information you can provide, the quicker and more accurately someone can help.
Locked
User avatar
phil
Site Admin
Posts: 5877
Joined: Sun Apr 06, 2003 11:12 pm

Re: XMBC 2.16 Beta

Post by phil » Thu May 04, 2017 10:00 pm

Here is 2.16 Beta 18.

If you have check for beta versions enabled, you should get notified of a new version and prompted to update in the next day or so. This is the most efficient method (bandwidth wise) as the updates are only a fraction of the size of the full install. Otherwise, you can get the full installation beta HERE. Note that this link will always get you the latest beta version!

Changes since v2.16 Beta 17:
  • #490 - Fixed a button drawing issue with classic style (no themes).
  • #488 - Modified behavior of the new {ACTIVATE} simkey tag for already active windows.
  • #475 - Fixed another issue switching profiles between various explorer.exe windows.
  • #478 - Fixed the ALT+P accelerator closing the window (changed the accelerator).
IMPORTANT: I have changed two accelerators '&' in the advanced settings tab (issue 478) as for some reason an ALT+P on the initial repeat rate label causes the window to close. ALT+P on any normal checkbox is fine though. So I swapped two accelerators - it was the best I could come up with!

Please make sure you dont use ALT+P as accelerators on labels (checkboxes are OK!) on this tab (or any tab).

Any problems, PM me a copy of the log file (or post a snippet in a code block here).

Thanks,
Phil
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-9600k, Asus Z390-ROG, 16GB DDR4,
nVidia GeForce GTX 970, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

User avatar
JTB3
Dedicated
Posts: 62
Joined: Thu Aug 04, 2016 1:52 am

Re: XMBC 2.16 Beta

Post by JTB3 » Thu May 04, 2017 10:29 pm

phil wrote:Here is 2.16 Beta 18.
Changes since v2.16 Beta 17:
  • #488 - Modified behavior of the new {ACTIVATE} simkey tag for already active windows.
  • #475 - Fixed another issue switching profiles between various explorer.exe windows.
  • #478 - Fixed the ALT+P accelerator closing the window (changed the accelerator).
...Any problems, PM me a copy of the log file (or post a snippet in a code block here).
Thanks, Phil
Hi Phil, Thx for the fast b18 update...
Sorry to report, however, that the issue I just reported with the 'desktop' profile not activating after an XMBC 'Close' command http://forums.highrez.co.uk/viewtopic.p ... 203#p13495 is still persistent (and has gotten worse! - 'Desktop' profile still does not re-activate even when closing non file-explorer windows).

My, unremarkable, logfile is attached. Let me know If I can provide any other info. -JT :)
XMouseButtonControl.zip
You do not have the required permissions to view the files attached to this post.
Last edited by JTB3 on Thu May 04, 2017 10:35 pm, edited 2 times in total.
System: Win10 Pro-x64 v1702+v1607, Intel i7-7700K (Z270) + i7-4771 (Z87)
Logitech M570 Wireless (5-Button) Trackball + M705 (5-Button) Marathon Mouse
[Bay Area, California]

User avatar
maxoku
Committed
Posts: 137
Joined: Sun Apr 02, 2017 5:21 pm

Re: XMBC 2.16 Beta

Post by maxoku » Thu May 04, 2017 10:31 pm

Buttons fixed, activate tag fixed, alt+p no longer have an OK function, but accelerator itself works properly, so it's been fixed. Unfortunately still problems with underlining, but well... ;p

Thanks Phil for fixing it. Yey :D

User avatar
phil
Site Admin
Posts: 5877
Joined: Sun Apr 06, 2003 11:12 pm

Re: XMBC 2.16 Beta

Post by phil » Thu May 04, 2017 10:35 pm

JTB3 wrote: Hi Phil, Thx for the fast b18 update...
Sorry to report, however, that the issue I just reported with the 'desktop' profile not activating after an XMBC 'Close' command http://forums.highrez.co.uk/viewtopic.p ... 203#p13495 is still persistent (and has gotten worse! - It appears to also not activate even when closing non file-explorer windows).
Thats odd - it appeared to work here... Perhaps it was too fast an update!
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-9600k, Asus Z390-ROG, 16GB DDR4,
nVidia GeForce GTX 970, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

User avatar
JTB3
Dedicated
Posts: 62
Joined: Thu Aug 04, 2016 1:52 am

Re: XMBC 2.16 Beta

Post by JTB3 » Thu May 04, 2017 10:40 pm

phil wrote:Thats odd - it appeared to work here... Perhaps it was too fast an update!
Ha! :lol: (awaiting any new insights! - and glad to hear of the other successful fixes from maxoku...)
System: Win10 Pro-x64 v1702+v1607, Intel i7-7700K (Z270) + i7-4771 (Z87)
Logitech M570 Wireless (5-Button) Trackball + M705 (5-Button) Marathon Mouse
[Bay Area, California]

User avatar
phil
Site Admin
Posts: 5877
Joined: Sun Apr 06, 2003 11:12 pm

Re: XMBC 2.16 Beta

Post by phil » Thu May 04, 2017 10:46 pm

DOH! - I'm going to rebuild 2.16 beta 18 and send you a an update to see if it fixes it...
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-9600k, Asus Z390-ROG, 16GB DDR4,
nVidia GeForce GTX 970, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

User avatar
JTB3
Dedicated
Posts: 62
Joined: Thu Aug 04, 2016 1:52 am

Re: XMBC 2.16 Beta

Post by JTB3 » Thu May 04, 2017 10:48 pm

phil wrote:DOH! - I'm going to rebuild 2.16 beta 18 and send you a an update to see if it fixes it...
Cool! 8)
System: Win10 Pro-x64 v1702+v1607, Intel i7-7700K (Z270) + i7-4771 (Z87)
Logitech M570 Wireless (5-Button) Trackball + M705 (5-Button) Marathon Mouse
[Bay Area, California]

User avatar
phil
Site Admin
Posts: 5877
Joined: Sun Apr 06, 2003 11:12 pm

Re: XMBC 2.16 Beta

Post by phil » Thu May 04, 2017 10:55 pm

Ive done it and replaced the previous beta - it should work now.

ALL: If you have already got beta 18 (the broken one), you can download it again now from the link above and it should fix that problem... I couldn't be bothered making a whole new beta when only 2 people had installed it :).

Any updates done from now should be good.
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-9600k, Asus Z390-ROG, 16GB DDR4,
nVidia GeForce GTX 970, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

User avatar
JTB3
Dedicated
Posts: 62
Joined: Thu Aug 04, 2016 1:52 am

Re: XMBC 2.16 Beta

Post by JTB3 » Thu May 04, 2017 11:08 pm

phil wrote:Beta 18 - I've done it and replaced the previous beta - it should work now.
Any updates done from now should be good.
Totally AWSOME! My preliminary tests are working great!
XMBC kicks ass!! :D -JT
System: Win10 Pro-x64 v1702+v1607, Intel i7-7700K (Z270) + i7-4771 (Z87)
Logitech M570 Wireless (5-Button) Trackball + M705 (5-Button) Marathon Mouse
[Bay Area, California]

User avatar
phil
Site Admin
Posts: 5877
Joined: Sun Apr 06, 2003 11:12 pm

Re: XMBC 2.16 Beta

Post by phil » Sat May 06, 2017 1:05 pm

OK I have got a problem on my computer at work, where the XMBC Auto Update always seems to get a cached version 2.16 Beta 14. I have cleared IE's cache, deleted the old installer (in the %temp% folder) and changed the code in XMBC and still it happens.

My last thoughts are that there may be some transparent internet cache between the computer and the server because after downloading a new update, it still appears to be 2.16 beta 14!

Is it just me or are others having this problem?
If its just me I'm less worried but this is a typical setup Windows 10 Pro PC so I expect its not just me :(.

I think it may be a problem with the download redirect page getting cached... Ive modified the page slightly to disable caching - I will see if it fixes the problem next week.
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-9600k, Asus Z390-ROG, 16GB DDR4,
nVidia GeForce GTX 970, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

User avatar
phil
Site Admin
Posts: 5877
Joined: Sun Apr 06, 2003 11:12 pm

Re: XMBC 2.16 Beta

Post by phil » Sun May 07, 2017 11:50 am

maxoku wrote:
Thu May 04, 2017 10:31 pm
Buttons fixed, activate tag fixed, alt+p no longer have an OK function, but accelerator itself works properly, so it's been fixed. Unfortunately still problems with underlining, but well... ;p

Thanks Phil for fixing it. Yey :D
Because its a multi-line control, the underlining gets confused and I cant for the life of me figure out why. I have tried all sorts of things and failed. The closest I got was having it always underlined (not just when you press ALT) but that didn't feel right either.... So I kind'a gave up trying any more :(.
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-9600k, Asus Z390-ROG, 16GB DDR4,
nVidia GeForce GTX 970, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

User avatar
JTB3
Dedicated
Posts: 62
Joined: Thu Aug 04, 2016 1:52 am

Re: XMBC 2.16 Beta

Post by JTB3 » Sun May 07, 2017 6:39 pm

phil wrote:
Sat May 06, 2017 1:05 pm
OK I have got a problem on my computer at work, where the XMBC Auto Update always seems to get a cached version 2.16 Beta 14....

Is it just me or are others having this problem? If its just me I'm less worried but this is a typical setup Windows 10 Pro PC so I expect its not just me :(.
Hi Phil,
I haven't noticed any recent problems with the auto-update on my W10 Pro AU machines. However, I performed the last Beta 18 (v2) update manually due to getting a prior update directly from you. I'll be sure to report if I notice any anomalies going forward :).
System: Win10 Pro-x64 v1702+v1607, Intel i7-7700K (Z270) + i7-4771 (Z87)
Logitech M570 Wireless (5-Button) Trackball + M705 (5-Button) Marathon Mouse
[Bay Area, California]

User avatar
JTB3
Dedicated
Posts: 62
Joined: Thu Aug 04, 2016 1:52 am

Re: XMBC 2.16 Beta 18 - BUG with New Activate Tag + Chrome Browser Windows

Post by JTB3 » Sun May 07, 2017 8:05 pm

phil wrote:
Thu May 04, 2017 10:00 pm
Here is 2.16 Beta 18 - Changes since v2.16 Beta 17:
  • #488 - Modified behavior of the new {ACTIVATE} simkey tag for already active windows.
  • #475 - Fixed another issue switching profiles between various explorer.exe windows.
Any problems ... Thanks, Phil
Hi Phil,
First off, the new Beta 18 {ACTIVATE} tag is working GREAT with almost everything I can throw at it! - and it has HUGELY improved the efficiency and speed in which one can navigate and close multiple windows on a large desktop setup. Congratulations, and many thanks! :)

After much testing, however, I've found only ONE important remaining issue (with 2 variations) related to Chrome browser windows NOT responding to the {ACTIVATE} tag. It is easily reproducible and I've provided a demo video link plus a zipped saved profile settings file + Chrome app shortcut that will, hopefully, quickly let you see the issue(s).

Bug Summary Description:
  • The main body of a Chrome 'App' window is NOT responding to the {Activate} tag - But the title-bar area IS responding normally.
  • The title bar area of a 'regular' Chrome (non-app) window is NOT responding to the {Activate} tag - But the main body area IS responding normally.
Here is my Video Demo link:
https://www.dropbox.com/s/q11ruhg7swz7g ... Issues.mp4

And here is a zipped demo profile+chrome app-window shortcut (.lnk) to help easily reproduce the bug:
216-Beta18-DemoProfile+ChromeAppShortcut.zip
-
Any assistance in fixing these (2) remaining niggles is super appreciated! :)
-JT
You do not have the required permissions to view the files attached to this post.
Last edited by JTB3 on Mon May 08, 2017 3:04 am, edited 1 time in total.
System: Win10 Pro-x64 v1702+v1607, Intel i7-7700K (Z270) + i7-4771 (Z87)
Logitech M570 Wireless (5-Button) Trackball + M705 (5-Button) Marathon Mouse
[Bay Area, California]

User avatar
phil
Site Admin
Posts: 5877
Joined: Sun Apr 06, 2003 11:12 pm

Re: XMBC 2.16 Beta

Post by phil » Sun May 07, 2017 9:05 pm

Oh typical - I bet it's because chrome 'tabs' are actually run out of process (separate exe's)... I'll try and take look tomorrow!
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-9600k, Asus Z390-ROG, 16GB DDR4,
nVidia GeForce GTX 970, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

User avatar
maxoku
Committed
Posts: 137
Joined: Sun Apr 02, 2017 5:21 pm

Re: XMBC 2.16 Beta

Post by maxoku » Mon May 08, 2017 1:57 am

phil wrote:
Sun May 07, 2017 11:50 am
maxoku wrote:
Thu May 04, 2017 10:31 pm
Unfortunately still problems with underlining, but well...
Because its a multi-line control, the underlining gets confused and I cant for the life of me figure out why. I have tried all sorts of things and failed. The closest I got was having it always underlined (not just when you press ALT) but that didn't feel right either.... So I kind'a gave up trying any more :(.
In English it's working fine, the problem is in other languages. :?

While the activate tag is working so great, maybe you'd consider to put it in the ui in the future. So users won't have to use simulated keys everytime to use it, but it would work with some options from the drop list as well like paste for example. :D

Well you fixed the main issue with the that button, but there are still two minor ones. First is that there is nothing when I hover it. It should look like unpressed (convex) button then :P . The second one is that when I press it it looks like it was pressed double time (double deep). Also if I press the button (hold it) and take the cursor out from the button it stays pressed, but one time. :lol:
It's not a big of a deal, but maybe one day you'll have some extra time, will be bored and in the super great mood and look into it. :P

I've reported that before but you probably missed it. In Modifier keys settings Other modifiers the access key for Slow down cursor is make it go focus to Enable modifier keys tickbox, but without ticking it. Before you ask there isn't any access key in English, but I added them in Polish. :lol:

Locked