Bug: Enhance Pointer Precision

x64 Replacement/Alternative to Microsoft's IntelliMouse application.
Forum rules
Please read the forum rules before posting for the first time.
The more information you can provide, the quicker and more accurately someone can help.
NOTE: To reduce spam, new users can not post links or images until they have at least 4 posts.
Post Reply
miQlo
Member
Posts: 15
Joined: Fri Oct 30, 2015 9:04 am

Bug: Enhance Pointer Precision

Post by miQlo » Mon Oct 17, 2016 6:20 pm

Hi,

Whenever I click Apply in the XMBC Setup dialog, the setting for Enhance Pointer Precision is turned on in the Windows default Mouse Properties. If I have the Mouse Properties window opened, I can't see the change take affect but it does. If I have the Mouse Properties window closed and hit Apply after a change in XMBC, the Enhance Pointer Precision setting is turned on, and if I open the Mouse Properties window I can now see a check mark there.

Is this repeatable or is it just me?


XMBC 2.14
Win 7 64 Pro
No-name mouse with Microsoft drivers

User avatar
phil
Site Admin
Posts: 5958
Joined: Sun Apr 06, 2003 11:12 pm

Re: Bug: Enhance Pointer Precision

Post by phil » Tue Oct 18, 2016 12:03 am

What is the "Enhance pointer precision" set to in XMBC general settings? If that is ticked, then I would expect it to turn on in Windows when you press apply. If its unticked, then it should turn off in Windows when you press apply.

Thanks,
Phil
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-9600k, Asus Z390-ROG, 16GB DDR4,
nVidia GeForce GTX 970, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

miQlo
Member
Posts: 15
Joined: Fri Oct 30, 2015 9:04 am

Re: Bug: Enhance Pointer Precision

Post by miQlo » Tue Oct 18, 2016 9:49 am

Hi Phil,

That was what I first thought but I didn't find the setting since I assumed it would be under the Scrolling & Navigation tab. Went to general settings and sure enough, there it was with a check mark.

My bug report fail rate for this app is 100%, miss the gun-to-the-head-smilie...


Thanks,
M

draek
New User
Posts: 2
Joined: Sun Oct 23, 2016 10:45 pm

Re: Bug: Enhance Pointer Precision

Post by draek » Sun Oct 23, 2016 10:47 pm

This newest version is turning Enhanced Pointer Precision on no matter what I do. I'll uncheck it and click ok/apply, it turns off and then turns itself back on again soon thereafter. It ran fun prior to 2.14, but I can't seem to find an older version anywhere so I can go back to it. Wish I hadn't updated.

EDIT:

To clarify, what's happening is that it defaults to on, and I'll turn it off, click ok/apply, and it will stay off until I minimize the application to my taskbar. Then it immediately turns back on.

User avatar
phil
Site Admin
Posts: 5958
Joined: Sun Apr 06, 2003 11:12 pm

Re: Bug: Enhance Pointer Precision

Post by phil » Tue Oct 25, 2016 1:42 am

OK I'll take a look - in the mean time, here is a link to 2.13.1 (the previous version).
https://www.highrez.co.uk/scripts/downl ... on=2130100

Thanks,
Phil
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-9600k, Asus Z390-ROG, 16GB DDR4,
nVidia GeForce GTX 970, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

draek
New User
Posts: 2
Joined: Sun Oct 23, 2016 10:45 pm

Re: Bug: Enhance Pointer Precision

Post by draek » Tue Oct 25, 2016 10:57 pm

Thank you. Back to normal with the older version. This is the best macro program out there, by the way. Thanks for your work on it.

User avatar
phil
Site Admin
Posts: 5958
Joined: Sun Apr 06, 2003 11:12 pm

Re: Bug: Enhance Pointer Precision

Post by phil » Sun Oct 30, 2016 3:47 pm

Good to hear that - I have found the problem - a very simple/stupid logic error when loading the settings!
It will be fixed in 2.15 beta 3 and on-wards.

Thanks,
Phil
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-9600k, Asus Z390-ROG, 16GB DDR4,
nVidia GeForce GTX 970, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

User avatar
menace97
New User
Posts: 10
Joined: Mon Nov 07, 2016 12:01 am

Re: Bug: Enhance Pointer Precision

Post by menace97 » Mon Nov 07, 2016 12:30 am

Just stumbled upon XMouse and I am very happy to have found it! Thank you for creating such a fantastic piece of software Phil.

I came to the forums almost immediately after I installed it and went to the Settings as I usually do to check out all the features. Granted, I hadn't read much, as I tend to delve right in, but initially I noticed that Enhance Pointer Precision was checked ON in Settings. I wasn't sure what that meant at first, thinking that this was the default behavior, but realized later that one has to select Okay for the Settings to take effect.

With playing games and for other purposes, many, including myself, tend to turn OFF the Microsoft's default Enhance Pointer Precision so there is no acceleration (if I have that correct).

Is there a chance in a future revision that XMouse would look at the current set value, and NOT change this behavior as a Setting Default?

In that same vein, I was curious if I went into the XMouse Settings and simply selected Okay immediately upon installing is there anything else that would change/override those standard settings of a typical mouse usually made through Microsoft Windows' proprietary software? Enhance Pointer Precision seemed to be the only feature that I noticed, the rest were very welcome improvements unique to the XMouse utility (note: I didn't touch Mouse Speed as typically I leave it in the middle #6 position on Microsoft's UI).

Thanks for any help and insight into if simply unchecking Enhance Pointer Precision in Settings, that would not affect the rest of the current mouse's basic settings.

Sincerely,
menace97

User avatar
phil
Site Admin
Posts: 5958
Joined: Sun Apr 06, 2003 11:12 pm

Re: Bug: Enhance Pointer Precision

Post by phil » Mon Nov 07, 2016 12:33 am

As should have been evident by the previous posts in this thread, there is a bug in 2.14 which turns the setting on when applying anything (even if you didn't touch it). It has already been fixed in 2.15 beta (available in the beta topic on the forum) which corrects that and leaves it untouched unless you actually go and turn it on.

And yes, no standard settings *should* be changed by simply applying a configuration. The only standard mouse settings tweakable by XMBC are pointer precision and speed, along with the number of line to scroll windows etc. By default it should not impact any Windows configurations, only if you want it to (when I don't make silly mistakes like the pointer precision in 2.14!)

Thanks,
Phil
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-9600k, Asus Z390-ROG, 16GB DDR4,
nVidia GeForce GTX 970, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

User avatar
menace97
New User
Posts: 10
Joined: Mon Nov 07, 2016 12:01 am

Re: Bug: Enhance Pointer Precision

Post by menace97 » Mon Nov 07, 2016 11:11 am

My apologies, it wasn't evident to me right away... but now I see that this was addressed. I honestly wasn't sure if my situation was just similar or if it was the same issue. I should've read the entire thread more thoroughly before posting.

Thanks for your assistance with my first visit here.

User avatar
phil
Site Admin
Posts: 5958
Joined: Sun Apr 06, 2003 11:12 pm

Re: Bug: Enhance Pointer Precision

Post by phil » Mon Nov 07, 2016 8:35 pm

No problem, at least your post was in the right thread - that's a refreshing change from most :lol:
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-9600k, Asus Z390-ROG, 16GB DDR4,
nVidia GeForce GTX 970, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

G4URD14N
New User
Posts: 1
Joined: Tue Nov 08, 2016 6:27 am

Re: Bug: Enhance Pointer Precision

Post by G4URD14N » Tue Nov 08, 2016 6:32 am

Wonderful. I really thought i was going crazy. Thank you so much for this software.

User avatar
menace97
New User
Posts: 10
Joined: Mon Nov 07, 2016 12:01 am

Re: Bug: Enhance Pointer Precision

Post by menace97 » Wed Nov 09, 2016 7:21 am

phil wrote:No problem, at least your post was in the right thread - that's a refreshing change from most :lol:
:angel:

Post Reply