I have upgraded the board - please let me know if you have any problems

Can't start XMBC on WinXP 32bit

x64 Replacement/Alternative to Microsoft's IntelliMouse application.
User avatar
injtsvetkov
Committed
Posts: 181
Joined: Mon Jun 06, 2016 8:51 am

Can't start XMBC on WinXP 32bit

Post by injtsvetkov » Tue Aug 30, 2016 8:50 am

Hi Phil,

I have read in the Overview that XMBC supports 32bit OS editions and the installation determines what version is required automatically during installation. I tried to install XMBC v2.14 Beta 8 on my old PC with WinXP 32bit SP3 but after the installation XMBC won't strat. Then I downloaded the portable version (v2.13.1) and tried to run the 32bit version but it didn't run either.
Any suggestions?

Thank you!
Iliya
HAMA Mirano
Windows 8.1 x64, Intel i5-3230M @ 2.60GHz, 4GB

User avatar
phil
Site Admin
Posts: 4875
Joined: Sun Apr 06, 2003 11:12 pm

Re: Can't start XMBC on WinXP 32bit

Post by phil » Tue Aug 30, 2016 9:03 am

Urm, XMBC now uses Visual Studio 2015 runtime - but it should still work on XP.
I will have to try it here and see if it works for me or not. Will let you know when I have done that.

Thanks
Phil
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-6600k, Asus 170-A, 16GB DDR4,
nVidia GeForce GTX 970, 2xEvo 850 (RAID 0), 2x2TB WD Black (RAID1)

User avatar
phil
Site Admin
Posts: 4875
Joined: Sun Apr 06, 2003 11:12 pm

Re: Can't start XMBC on WinXP 32bit

Post by phil » Tue Aug 30, 2016 9:08 am

Just installed on an old Windows XP SP2 32bit VM and it runs fine here - so I don't know what to suggest :(
I'll install SP3 and check that later.
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-6600k, Asus 170-A, 16GB DDR4,
nVidia GeForce GTX 970, 2xEvo 850 (RAID 0), 2x2TB WD Black (RAID1)

User avatar
injtsvetkov
Committed
Posts: 181
Joined: Mon Jun 06, 2016 8:51 am

Re: Can't start XMBC on WinXP 32bit

Post by injtsvetkov » Tue Aug 30, 2016 12:19 pm

Thanks Phil, no hurry though! It's an old quite slow PC at work and maybe it's time for reinstalling windows. I have an XP 32bit SP2 PC at home so tonight I'll try it there.

Greetings!
Iliya
HAMA Mirano
Windows 8.1 x64, Intel i5-3230M @ 2.60GHz, 4GB

User avatar
injtsvetkov
Committed
Posts: 181
Joined: Mon Jun 06, 2016 8:51 am

Re: Can't start XMBC on WinXP 32bit

Post by injtsvetkov » Tue Aug 30, 2016 8:31 pm

No luck on XP 32bit SP2 either :(
Any suggestions about something I should have installed like .NET or anything else that XP needs to run Visual Studio 2015 apps?
HAMA Mirano
Windows 8.1 x64, Intel i5-3230M @ 2.60GHz, 4GB

User avatar
phil
Site Admin
Posts: 4875
Joined: Sun Apr 06, 2003 11:12 pm

Re: Can't start XMBC on WinXP 32bit

Post by phil » Tue Aug 30, 2016 10:41 pm

No need for .net!
You could try the c++ 2015 run times but that shouldn't be needed either. Odd how its working fine for me - what AV do you use? Anything else odd?

I presume the installer works? can you send me the file checksums of the exe and dll under program files\highresolution enterprises\XMouseButtonControl - to ensure they match mine?

Anything in the system/application event log?
Anything in the XMBC log? (In your user profile appdata - C:\Users\<your username>\AppData\Roaming\Highresolution Enterprises\XMouseButtonControl)

Thanks,
Phil
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-6600k, Asus 170-A, 16GB DDR4,
nVidia GeForce GTX 970, 2xEvo 850 (RAID 0), 2x2TB WD Black (RAID1)

User avatar
injtsvetkov
Committed
Posts: 181
Joined: Mon Jun 06, 2016 8:51 am

Re: Can't start XMBC on WinXP 32bit

Post by injtsvetkov » Wed Aug 31, 2016 8:24 pm

Yes, the installer works fine, it completes the installation normally and when it asks whether to open XMBC I click OK and the homepage opens in my browser but XMBC doesn't start :(

On the PC with SP3 I have Avast AV but I always shut it down at windows startup coz it's too slow, so I doubt it.
On the PC with SP2 I have Nod32, but it isn't reacting at all while installing and starting the XMBC's .exe, nor when I start the 32bit portable version.

Have you got c++ 2015 run times on your XP 32bit VM?

I am out of town till the weekend, so I can't give you more info now, but when I get back home I'll send all you're asking for.

Thank you!
Iliya
HAMA Mirano
Windows 8.1 x64, Intel i5-3230M @ 2.60GHz, 4GB

User avatar
phil
Site Admin
Posts: 4875
Joined: Sun Apr 06, 2003 11:12 pm

Re: Can't start XMBC on WinXP 32bit

Post by phil » Wed Aug 31, 2016 9:49 pm

I haven't got the 2015 runtimes installed - its a bit of a stab in the dark suggesting it but I have no idea what else the problem could be.

Will try and play around here but its a bit tricky as it works for me. Will try a fresh XPSP3 install and try and get all the post SP3 updates (are they still available?!)
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-6600k, Asus 170-A, 16GB DDR4,
nVidia GeForce GTX 970, 2xEvo 850 (RAID 0), 2x2TB WD Black (RAID1)

User avatar
injtsvetkov
Committed
Posts: 181
Joined: Mon Jun 06, 2016 8:51 am

Re: Can't start XMBC on WinXP 32bit

Post by injtsvetkov » Wed Aug 31, 2016 10:46 pm

I've played around with the services (on both machines) in the past (disabling some useless services) but all essential services are running and I've never had such issues with other software. Anyway can you think of some service that could be crucial for XMBC and not needed for other software?
Is XMBC supposed to work in Safe Mode?

If there is no one else complaining about that I would suggest that you don't waste your time coz I suspect there might be something that I've done (as the problem is present on both my machines) and I'm gonna find out what is it!

About the post SP3 updates, I don't know but I usually disable the windows update option so probably I haven't got the latest ones.

Thank you!
Iliya
HAMA Mirano
Windows 8.1 x64, Intel i5-3230M @ 2.60GHz, 4GB

User avatar
phil
Site Admin
Posts: 4875
Joined: Sun Apr 06, 2003 11:12 pm

Re: Can't start XMBC on WinXP 32bit

Post by phil » Wed Aug 31, 2016 10:59 pm

I don't know about safe mode - Ive never tried.
But XMBC does not rely on and windows services so I doubt that is it!
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-6600k, Asus 170-A, 16GB DDR4,
nVidia GeForce GTX 970, 2xEvo 850 (RAID 0), 2x2TB WD Black (RAID1)

User avatar
injtsvetkov
Committed
Posts: 181
Joined: Mon Jun 06, 2016 8:51 am

Re: Can't start XMBC on WinXP 32bit

Post by injtsvetkov » Fri Sep 02, 2016 6:23 pm

I installed 'Visual C++ Redistributable for Visual Studio 2015' (13.1mb), but no difference :(

I opened the 'Event viewer' and tried to start both installed and portable versions but nothing gets logged in system or application logs at that moment.

Tried starting both in safe mode - unsuccessfully.

There isn't XMBC log file under 'C:\Documents and Settings\Iliq\Application Data\Highresolution Enterprises\XMouseButtonControl', there are only language templates in it.

Here are the checksums of the files: http://dox.bg/files/dw?a=5b8687f7f8

In System Properties it says:

Microsoft Windows XP
Professional
Version 2002
Service Pack 2

Could this 'Version 2002' be the problem (what's the version of your VM)?

Thank you!
Iliya
HAMA Mirano
Windows 8.1 x64, Intel i5-3230M @ 2.60GHz, 4GB

User avatar
injtsvetkov
Committed
Posts: 181
Joined: Mon Jun 06, 2016 8:51 am

Re: Can't start XMBC on WinXP 32bit

Post by injtsvetkov » Sun Sep 04, 2016 11:25 pm

Can you send me some old version of XMBC (maybe before 2.10) to try to install and run it!

Thanks!
Iliya
HAMA Mirano
Windows 8.1 x64, Intel i5-3230M @ 2.60GHz, 4GB

User avatar
phil
Site Admin
Posts: 4875
Joined: Sun Apr 06, 2003 11:12 pm

Re: Can't start XMBC on WinXP 32bit

Post by phil » Mon Sep 05, 2016 1:19 am

--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-6600k, Asus 170-A, 16GB DDR4,
nVidia GeForce GTX 970, 2xEvo 850 (RAID 0), 2x2TB WD Black (RAID1)

User avatar
injtsvetkov
Committed
Posts: 181
Joined: Mon Jun 06, 2016 8:51 am

Re: Can't start XMBC on WinXP 32bit

Post by injtsvetkov » Wed Sep 07, 2016 8:44 am

Hi Phil, thanks for the links!

Here is the situation on winXP 23bit SP3:

Installed v2.10.2 - works fine, Updated to v2.13.1 - stopped working!

Installed v2.11.1 - works fine, Updated to v2.14 Beta 9 - stopped working!

Installed v2.12.1 - works fine, Updated to v2.14 Beta 9 - stopped working!

Apparently there has been some change in v2.13.1, but wonder what would it be as it works on your VM and not on my PC. Have you tried on a real PC or only on VM (is it possible to be hardware related)?

Greetings!
Iliya
HAMA Mirano
Windows 8.1 x64, Intel i5-3230M @ 2.60GHz, 4GB

User avatar
phil
Site Admin
Posts: 4875
Joined: Sun Apr 06, 2003 11:12 pm

Re: Can't start XMBC on WinXP 32bit

Post by phil » Wed Sep 07, 2016 9:42 am

Hi, that's interesting... I think the change to visual studio 2015 was in 2.13 I think so that is probably related.

The burning question is why does it work for me and not you - I don't have a real machine with XP on it (for about 10 years!) but don't see how a VM would be any different XMBC does not go near the hardware - its purly a software thing.

I'll try setting up a fresh VM and see what happens with that when I get a minute.
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-6600k, Asus 170-A, 16GB DDR4,
nVidia GeForce GTX 970, 2xEvo 850 (RAID 0), 2x2TB WD Black (RAID1)

Post Reply

Who is online

Users browsing this forum: Google [Bot] and 1 guest