[BUG] Back and Forward actions not working with Edge browser

x64 Replacement/Alternative to Microsoft's IntelliMouse application.
Forum rules
Please read the forum rules before posting for the first time.
The more information you can provide, the quicker and more accurately someone can help.
NOTE: To reduce spam, new users can not post links or images until they have at least 4 posts.
Post Reply
hexaae
New User
Posts: 7
Joined: Mon Jun 06, 2016 1:47 pm

[BUG] Back and Forward actions not working with Edge browser

Post by hexaae » Mon Jun 06, 2016 1:54 pm

Windows 10 x64, UAC at maximum (confirm all actions), Edge browser.

Unfortunately Back and Forward actions do not work with Edge browser :(
IE11 and other browsers (or Explorer itself) have no issues.
I configured Back and Forward for mouse wheel tilt left-right with Microsoft PN7-00004 Mobile 3600 Mouse.

Please, can you investigate and fix it?

hexaae
New User
Posts: 7
Joined: Mon Jun 06, 2016 1:47 pm

Re: [BUG] Back and Forward actions not working with Edge browser

Post by hexaae » Mon Jun 06, 2016 2:04 pm

As a workaround I've defined another layer specifically for "microsoftedge.exe" with the following input keys:
{LALT}{LEFT}
{LALT}{RIGHT}
and works fine :) ...but shouldn't be necessary AFAICU.

User avatar
phil
Site Admin
Posts: 6074
Joined: Sun Apr 06, 2003 11:12 pm

Re: [BUG] Back and Forward actions not working with Edge browser

Post by phil » Tue Jun 07, 2016 12:24 am

That is very odd - the back/forward actions are defaults for button 4 and 5 - so why they would not work and only in edge is very odd. I will see what I can find.
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-9600k, Asus Z390-ROG, 16GB DDR4,
nVidia GeForce GTX 970, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

hexaae
New User
Posts: 7
Joined: Mon Jun 06, 2016 1:47 pm

Re: [BUG] Back and Forward actions not working with Edge browser

Post by hexaae » Wed Jun 08, 2016 3:28 pm

Great!
Amazing tool: I can avoid downloading 150MB of bloatware from MS or Logitech :D ... and can do more with XMouse!

User avatar
phil
Site Admin
Posts: 6074
Joined: Sun Apr 06, 2003 11:12 pm

Re: [BUG] Back and Forward actions not working with Edge browser

Post by phil » Sun Jun 26, 2016 12:17 pm

OK EDGE (and I suspect all modern UI windows) don't respond to the WM_APPCOMMAND message that XMBC sends. In 2.14 beta 2, I have added a work around (which essentially sends keys) for modern UI applications.

Thanks,
Phil
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-9600k, Asus Z390-ROG, 16GB DDR4,
nVidia GeForce GTX 970, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

Post Reply