"Scroll window under cursor" breaks Windows Store apps

x64 Replacement/Alternative to Microsoft's IntelliMouse application.
Forum rules
Please read the forum rules before posting for the first time.
The more information you can provide, the quicker and more accurately someone can help.
NOTE: To reduce spam, new users can not post links or images until they have at least 4 posts.
Post Reply
theevenger
New User
Posts: 1
Joined: Thu Jul 09, 2015 4:47 pm

"Scroll window under cursor" breaks Windows Store apps

Post by theevenger »

Hello,

I'm hoping there might be a way around this.

If "Make scroll wheel scroll window under cursor" is set to ON, *all* mouse wheel scrolling is disabled in my Windows Store apps. I have to turn the setting off in order to scroll in those apps at all.

OS: Win 8.1 Pro (x64) with current updates (including the "desktop friendliizer" update that gave the min/close buttons when using mouse/keyboard).

User avatar
phil
Site Admin
Posts: 6403
Joined: Sun Apr 06, 2003 11:12 pm

Re: "Scroll window under cursor" breaks Windows Store apps

Post by phil »

What version of XMBC are you using? Seems to be working fine here for me. Can you perhaps list some of the apps? I've only tried in the stock news app and a few others so far.

There was a problem when Win 8.1 first came out but that was resolved <years ago>!

Perhaps you could enable debug logging for me (advanced settings tab). OK/Apply that and then open up a store app, scroll in it and then send me a copy of the logfile (after turning debug logging back off!).
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-9600k, Asus Z390-ROG, 16GB DDR4,
nVidia GeForce GTX 970, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

piyo
Member
Posts: 20
Joined: Wed Jul 31, 2013 6:58 am

Re: "Scroll window under cursor" breaks Windows Store apps

Post by piyo »

Hi,
phil wrote: There was a problem when Win 8.1 first came out but that was resolved <years ago>!
Yes, you fixed the problem and at least it worked well with SMBC 2.8.x.
Currently I'm still using SMBC 2.9.2 on Windows 8.1 PC, and having the same problem with theevenger.
So, at least SMBC 2.9.2 having this problem. and I also tested SMBC 2.10.x before, and was the same result.

I noticed this problem but I didn't report it, because there is a workaround as theevenger wrote, and I will migrate to Windows 10 soon.

User avatar
phil
Site Admin
Posts: 6403
Joined: Sun Apr 06, 2003 11:12 pm

Re: "Scroll window under cursor" breaks Windows Store apps

Post by phil »

SMBC? :)

I need details. I'm on 8.1 on all my various PC's except my SP2 which is on Win 10. I dont see any problems scrolling with 8.1 store apps but I dont use them very often so some more detail would be good. Which apps, what is the effect (always no scrolling, random etc.) and ideally some debug logging so I can see if the "fix" I made is getting used or not - quite possibly, the window class is not what XMBC is looking for so its not applying my fix!

Of course, in XMBC 2.10 you can now also disable the scroll window under cursor on an app by app or window by window basis using app/window profiles and the scrolling and navigation tab.

Thanks
Phil
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-9600k, Asus Z390-ROG, 16GB DDR4,
nVidia GeForce GTX 970, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

User avatar
phil
Site Admin
Posts: 6403
Joined: Sun Apr 06, 2003 11:12 pm

Re: "Scroll window under cursor" breaks Windows Store apps

Post by phil »

theevenger wrote:I'm hoping there might be a way around this.
Can you try this for me... In XMBC, press the "Add" button to create a new profile.
Press the "Specific Window" button
Ensure CAPSLOCK if OFF
Tick the "Hover" checkbox
Open a windows store app that has the scrolling problem. Once it loads, turn on CAPSLOCK
Go back to XMBC and have a look in the Find Window dialog....

What is the Window class?

Press OK to save the profile and then select it in the list from the main XMBC screen.
Select the "Scrolling and navigation" tab and check the "Disable Scroll Window Under Cursor" option.
Apply your changes

See if that fixes the scrolling in metro/store apps - and let me know! :)

Thanks,
Phil
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-9600k, Asus Z390-ROG, 16GB DDR4,
nVidia GeForce GTX 970, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

Post Reply