XMBC 2.7 Beta

x64 Replacement/Alternative to Microsoft's IntelliMouse application.
Forum rules
Please read the forum rules before posting for the first time.
The more information you can provide, the quicker and more accurately someone can help.
NOTE: To reduce spam, new users can not post links or images until they have at least 4 posts.
User avatar
phil
Site Admin
Posts: 6543
Joined: Sun Apr 06, 2003 11:12 pm

Re: XMBC 2.7 Beta

Post by phil »

Sorry Tros, but there wont be anything for this in the next beta or release. As I said, if the existing options dont work, then the only answer is a big re-write of the core code, and even then I dont yet know if it will be possible. Its already a long outstanding issue (and long outstanding issues tend to stay that way because there are complicated and I don't have much time!).
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-9600k, Asus Z390-ROG, 16GB DDR4,
nVidia GeForce GTX 970, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

User avatar
phil
Site Admin
Posts: 6543
Joined: Sun Apr 06, 2003 11:12 pm

Re: XMBC 2.7 Beta

Post by phil »

OK Here is 2.7 Beta 5.

You can get the beta HERE. Note that this link will always get you the latest beta version!

Changes since v2.7b5:
  • #207 - Added option to Simulated keystrokes to allow user to tell XMBC to block/not block the mouse button input when sending the keystrokes. Block original mouse input is enabled by default so it behaves as it always has done.
  • #209 - Fixed bugs reported by Piro regarding the new option added in 2.7 Beta 4.
  • Misc bug fixes and spelling fixes (Translators, please check out the updated language template in the installer)
As usual, let me know if/when things go wrong!
Thanks,
Phil
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-9600k, Asus Z390-ROG, 16GB DDR4,
nVidia GeForce GTX 970, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

User avatar
phil
Site Admin
Posts: 6543
Joined: Sun Apr 06, 2003 11:12 pm

Re: XMBC 2.7 Beta

Post by phil »

OK Here is 2.7 Beta 6.

You can get the beta HERE. Note that this link will always get you the latest beta version!

Changes since v2.7b6:
  • #207 - Fixed error message when setting simulated keystrokes on a button.
  • #213 - Reduced overhead when scrolling th wheel very fast to try and prevent system beeps
As usual, let me know if/when things go wrong!
Thanks,
Phil
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-9600k, Asus Z390-ROG, 16GB DDR4,
nVidia GeForce GTX 970, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

User avatar
AndyK
Committed
Posts: 156
Joined: Mon Jan 06, 2014 4:38 pm

Re: XMBC 2.7 Beta

Post by AndyK »

Hi, every click on "About" tells me there is an new version available.
I use XMBC 2.7 Beta6

Image: http://www.imagenetz.de/img.php?file=8c21920e0b.png

Andy

User avatar
phil
Site Admin
Posts: 6543
Joined: Sun Apr 06, 2003 11:12 pm

Re: XMBC 2.7 Beta

Post by phil »

Yes I know, I got the internal version wrong (I didn't change it). I had noticed this too but well done for reporting it :)

I will fix that in the next beta rather than change the version check on the server (thats not worth it).

Thanks,
Phil
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-9600k, Asus Z390-ROG, 16GB DDR4,
nVidia GeForce GTX 970, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

User avatar
phil
Site Admin
Posts: 6543
Joined: Sun Apr 06, 2003 11:12 pm

Re: XMBC 2.7 Beta

Post by phil »

OK Here is 2.7 Beta 7.

You can get the beta HERE. Note that this link will always get you the latest beta version!

Changes since v2.7b6:
  • Updated some language templates and fixed some spelling errors
As usual, let me know if/when things go wrong!
Thanks,
Phil
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-9600k, Asus Z390-ROG, 16GB DDR4,
nVidia GeForce GTX 970, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

User avatar
phil
Site Admin
Posts: 6543
Joined: Sun Apr 06, 2003 11:12 pm

Re: XMBC 2.7 Beta

Post by phil »

Oops - I missed one. If you downloaded beta 7 before 14:36 UTC then please try again!

Thanks
Phil
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-9600k, Asus Z390-ROG, 16GB DDR4,
nVidia GeForce GTX 970, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

User avatar
phil
Site Admin
Posts: 6543
Joined: Sun Apr 06, 2003 11:12 pm

Re: XMBC 2.7 Beta

Post by phil »

OK Here is 2.7 Beta 8.

You can get the beta HERE. Note that this link will always get you the latest beta version!

Changes since v2.7b7:
  • Fixed some scrolling window under cursor bugs introduced in Beta 6
  • Added some specific window code for Mozilla Firefox plugins (eg. flash) which didn't always work with scroll window under cursor.
As usual, let me know if/when things go wrong! I think were getting close to 2.7 now - although there are things like holidays that might get in the way of that in the near future :)
Thanks,
Phil
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-9600k, Asus Z390-ROG, 16GB DDR4,
nVidia GeForce GTX 970, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

lee321987
New User
Posts: 10
Joined: Fri Feb 12, 2010 5:53 pm

Re: XMBC 2.7 Beta

Post by lee321987 »

Hi Phil.
2.7 Beta 8 is messing up the previews in Windows Taskbar (Win7 x64).

When I hover over a running program's icon in the Taskbar, the preview pops up and disappears very fast (milliseconds).

If you move the pointer around (staying on the same icon), the preview flashes on/off very rapidly, but as soon as you stop, it disappears.

If you click a blank spot on the taskbar before hovering, then preview works right.
Also if you click on the window of certain programs (e.g. Notepad++) before trying a hover then it woks right.

I'm having trouble repeating this bug. It seems to take a bit to start happening, but closing XMBC instantly makes previews start working right.

Firefox and/or VLC media player may have something to do with it, or make it happen faster -- I don't know for sure.

User avatar
phil
Site Admin
Posts: 6543
Joined: Sun Apr 06, 2003 11:12 pm

Re: XMBC 2.7 Beta

Post by phil »

Thanks for the info. I've not been able to reproduce this on Win8 but I will give it a go on my Win 7 VM ASAP.
I use both firefox and vlc so hopefully I can recreate it.

Do you have any specific profiles that run for the task bar?

EDIT: If you turn on debug logging it might be useful to get a snippet of that too.

Thanks,
Phil
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-9600k, Asus Z390-ROG, 16GB DDR4,
nVidia GeForce GTX 970, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

User avatar
phil
Site Admin
Posts: 6543
Joined: Sun Apr 06, 2003 11:12 pm

Re: XMBC 2.7 Beta

Post by phil »

lee321987 wrote:Hi Phil.
2.7 Beta 8 is messing up the previews in Windows Taskbar (Win7 x64).
----
I'm having trouble repeating this bug. It seems to take a bit to start happening, but closing XMBC instantly makes previews start working right.

Firefox and/or VLC media player may have something to do with it, or make it happen faster -- I don't know for sure.
I have still not been able to reproduce this one... even with firefox and VLC :(
Any more clues on your setup (how many profiles, what configuration etc.) that might make it more obvious?

Thanks,
Phil
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-9600k, Asus Z390-ROG, 16GB DDR4,
nVidia GeForce GTX 970, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

lee321987
New User
Posts: 10
Joined: Fri Feb 12, 2010 5:53 pm

Re: XMBC 2.7 Beta

Post by lee321987 »

I've noticed another part of this bug (I assume): after a while the CPU usage of XMBC goes up to a constant ~5%, and once it gets that high, right-clicking the XMBC tray icon causes it to instantly close/crash.

I enabled debug logging for a few minutes and these three message stood out to me:

Code: Select all

Unable to enter critical section in ScrollLinesTimerProc    (appeared ~48000 times)
Unable to enter critical section in KeySwitchTimerProc   (appeared 161 times)
KeySwitchTimerProc fired	(appeared ~850000 times)
So far I have found two programs that enabling their XMBC profile causes the bug: Firefox, and Directory Opus. After enabling the profile, everything seems normal, but as soon as I give focus to the window (of the profile i just enabled) then the taskbar instantly starts showing this bug.

Seeing the word "timer" in the error messages made me think this could be useful: My motherboard's HPET (High Precision Even Timer) is enabled in BIOS, and I configured Windows 7 to use it.
Also, the HPET does not have a 32-bit/64-bit option (I assume it's running in 32?). I only run Win7 x64.

Sorry I connected this to VLC -- I'm pretty sure I was wrong about that.

Attached are my XMBC settings and the profiles of Firefox and Directory Opus.

Please let me know if there is anything else I can do to help.

(EDIT: changed attachment -- forgot Default profile)
You do not have the required permissions to view the files attached to this post.

User avatar
phil
Site Admin
Posts: 6543
Joined: Sun Apr 06, 2003 11:12 pm

Re: XMBC 2.7 Beta

Post by phil »

Thanks - that looks like it might be interesting.

Can you send me that log file (it might be an idea to turn on debug logging also to provide more context).
Can you also send me the full XMBCSettings.XML file (in the same folder as the log file - hint: you can hold CTRL and left click the XMBC icon to open explorer on that folder)

I will try and have a look tonight, if not then chances are I will find some time this weekend :)

Thanks,
Phil
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-9600k, Asus Z390-ROG, 16GB DDR4,
nVidia GeForce GTX 970, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

lee321987
New User
Posts: 10
Joined: Fri Feb 12, 2010 5:53 pm

Re: XMBC 2.7 Beta

Post by lee321987 »

Sorry, after the test, I deleted the lines in the log generated by the debug logging.
So I just re-enabled debug logging, and ran it till the bug showed. The log and settings file are attached.
Debug logging was enabled on line 4508.

If you want a longer test, just tell me how long/big of a log file you want.
You do not have the required permissions to view the files attached to this post.

User avatar
phil
Site Admin
Posts: 6543
Joined: Sun Apr 06, 2003 11:12 pm

Re: XMBC 2.7 Beta

Post by phil »

OK Thanks for the logs. I have sent you a PM.
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-9600k, Asus Z390-ROG, 16GB DDR4,
nVidia GeForce GTX 970, Evo 970 500Gb NVME, 2x2TB WD Black (RAID1)

Locked