Guild Wars 2 and weird scroll button behaviour

x64 Replacement/Alternative to Microsoft's IntelliMouse application.
Forum rules
Please read the forum rules before posting for the first time.
The more information you can provide, the quicker and more accurately someone can help.
Post Reply
New User
Posts: 1
Joined: Thu May 30, 2013 9:32 am

Guild Wars 2 and weird scroll button behaviour

Post by Wrek » Thu May 30, 2013 9:49 am

Hi. I use XMBC for my games where the mouse scroll wheel is not supported and is generelly locked to zoom in/out. I like to use my 4 way scroll button for abilites so have tried to set up XMBC so that it uses PGUP and PGDN (or others) for mouse scroll functions. Then I bind abilities in game to PGUP/PGDN and I'm good to go.

The problem with GuildWars2 is that the scroll down button on my mouse also makes my character jump in the game too and I cannot figure out why, my character jumps every time just like I am hitting the space bar too at the same time, but I am not. Scrolling up and thereby emulating PGUP doesn't do it. It only does it on the down stroke. Its not any in-game settings I've gone mad checking (and its not the evade mechanic). There is a 40ms delay between simualted keystrokes in XMBC but again here if thats the culprit then it should replicate the problem when I scroll up on the mouse, no?

I can live with it as it does fire off the right abilites, but its annoying after a while, moreso because I cannot fix it. Any help appreciated.

Win8 x64
Logitech G 700 mouse
Logitech gaming Software 8.45.88

EDIT: Okay I've just load up Rift as thats another game that doesn't offer scroll wheel support and is locked to zoom in/out. Using the same basic settings in XMBC my character in Rift also jumps on scroll down (scroll wheel is now set to emulate uparrow & downarrow this time). So it doesn't look like its game specific.

Post Reply