I have upgraded the board - please let me know if you have any problems

Can't start XMBC on WinXP 32bit

x64 Replacement/Alternative to Microsoft's IntelliMouse application.
User avatar
phil
Site Admin
Posts: 5028
Joined: Sun Apr 06, 2003 11:12 pm

Re: Can't start XMBC on WinXP 32bit

Post by phil » Sun Sep 11, 2016 7:41 pm

OK try 2.14 Beta 12 - and use the DebugView
I have added a couple more debug lines right at the very start of the program - so we can see if they come out!

Thanks
Phil
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-6600k, Asus 170-A, 16GB DDR4,
nVidia GeForce GTX 970, 2xEvo 850 (RAID 0), 2x2TB WD Black (RAID1)

User avatar
injtsvetkov
Committed
Posts: 194
Joined: Mon Jun 06, 2016 8:51 am

Re: Can't start XMBC on WinXP 32bit

Post by injtsvetkov » Sun Sep 11, 2016 8:42 pm

OK so I opened the DebugViewer and downloaded the installer of 2.14 beta 12 and run it. The installation completed and the default browser started to open the home page. Those 3 lines showed up in DebugViewer at XMBC's first startup.

00000001 0.00000000 [3972] ExecShellAsUser: DLL_PROCESS_ATTACH
00000002 0.00182649 [3972] ExecShellAsUser: process is not elevated, will fallback to ShellExecute
00000003 0.24130943 [3972] ExecShellAsUser: DLL_PROCESS_DETACH


I closed the DebugViewer and opened it again, then tried to start XMBC again (by the way the .exe doesn't show up every time) and when the .exe showed up again for a sec - nothing showed up in the DebugViewer this time. I even tried from cmd with /debug tag but again nothing :(. They showed up only the first time after the install!

After a while I looked at the DebugViewer and those lines were in it too but I don't know where did they come from:

00000004 74.45348358 [1508] Start
00000005 74.45357513 [1508] CPL_INIT
00000006 74.76918030 [1508] Start
00000007 74.76923370 [1508] CPL_GETCOUNT
00000008 74.77722931 [1508] Start
00000009 74.77730560 [1508] CPL_INQUIRE
00000010 74.77738190 [1508] Start
00000011 74.77742004 [1508] CPL_NEWINQUIRE
00000012 74.85748291 [1508] Start
00000013 74.89227295 [1508] CPL_STOP
00000014 74.89232635 [1508] Start
00000015 74.90129852 [1508] CPL_EXIT
HAMA Mirano
Windows 8.1 x64, Intel i5-3230M @ 2.60GHz, 4GB

User avatar
phil
Site Admin
Posts: 5028
Joined: Sun Apr 06, 2003 11:12 pm

Re: Can't start XMBC on WinXP 32bit

Post by phil » Sun Sep 11, 2016 10:02 pm

Debugview shows any debug, system wide. None of that is from XMBC. So its not even calling the initial program before it dies - that leaves me back at square one with no idea whats going on!
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-6600k, Asus 170-A, 16GB DDR4,
nVidia GeForce GTX 970, 2xEvo 850 (RAID 0), 2x2TB WD Black (RAID1)

User avatar
injtsvetkov
Committed
Posts: 194
Joined: Mon Jun 06, 2016 8:51 am

Re: Can't start XMBC on WinXP 32bit

Post by injtsvetkov » Mon Oct 03, 2016 7:38 pm

Hey Phil, it turned out that my Admin account was not visible. I created new entry in the registry and when I logged on with it, the default XMBC install folder in 'C:\Program files' was empty. I installed v2.14 under program files but again no luck :(
I've read somewhere that XMBC runs as an accessibility tool to interact with elevated processes. Could it be possible that sometihing has gotten wrong while this admin account was not visible?
HAMA Mirano
Windows 8.1 x64, Intel i5-3230M @ 2.60GHz, 4GB

User avatar
phil
Site Admin
Posts: 5028
Joined: Sun Apr 06, 2003 11:12 pm

Re: Can't start XMBC on WinXP 32bit

Post by phil » Mon Oct 03, 2016 9:29 pm

Elevated permissions and accessibility tools do not apply to XP, XP does not have UAC so nothing to do with that. And an invisible admin account should make no difference at all!
--[ Phil ]--
--[ Administrator & XMBC Author ]--
Logitech G9, Logitech MX518, Microsoft Intellimouse, Trust 16341 BT Mouse
Windows 10 x64, Intel i5-6600k, Asus 170-A, 16GB DDR4,
nVidia GeForce GTX 970, 2xEvo 850 (RAID 0), 2x2TB WD Black (RAID1)

User avatar
maxoku
Dedicated
Posts: 96
Joined: Sun Apr 02, 2017 5:21 pm

Re: Can't start XMBC on WinXP 32bit

Post by maxoku » Fri Apr 21, 2017 3:20 pm

If it appears in task manager for a moment and then closes, it might be just prevented by the system by a tool or other application like antivirus. Check what applications of that kind could be running and whitelist XMBC there or just turn them off if possible. The same for the Windows tools like DEP (Data Execution Prevention). Check also what else is going on the in task manager. Maybe any new application will appear at the moment or another will work intensively and take some CPU?

Try to check the user permissions or if file isn't blocked, but probably not if it appears in task manager even for a bit. Try to find out if there was any update for WinXP that fixes problems with VS2015 or file's execution. It might be included in SP3 or was put separately. I have SP3 and all recommended updates, so maybe one of them helps XMBC to work.

User avatar
injtsvetkov
Committed
Posts: 194
Joined: Mon Jun 06, 2016 8:51 am

Re: Can't start XMBC on WinXP 32bit

Post by injtsvetkov » Tue May 02, 2017 9:37 am

maxoku wrote:Try to find out if there was any update for WinXP that fixes problems with VS2015 or file's execution. It might be included in SP3 or was put separately. I have SP3 and all recommended updates, so maybe one of them helps XMBC to work.
Thanks for your reply mate :)
Since I've checked all other things and no luck, it seems that the only thing left is install all updates and see what happens. I searched for such VS2015 related updates but didn't find anything specific so now I am installing all available winXP updates (also installed the latest SP3) and see what happens. Unfortunately I have installed the most of them already but still nothing changed :( not even a bit! It gave me some errors and didn't install a couple of updates so these are my last hope, I'll see if I can manage to install them today :roll:

Thanks again!
Iliya
HAMA Mirano
Windows 8.1 x64, Intel i5-3230M @ 2.60GHz, 4GB

User avatar
sukemaru
Dedicated
Posts: 43
Joined: Tue Oct 18, 2016 7:21 pm

Re: Can't start XMBC on WinXP 32bit

Post by sukemaru » Tue May 02, 2017 2:15 pm

@ injtsvetkov
This is a reminder that I have replied to your PM.

suke

User avatar
maxoku
Dedicated
Posts: 96
Joined: Sun Apr 02, 2017 5:21 pm

Re: Can't start XMBC on WinXP 32bit

Post by maxoku » Tue May 02, 2017 3:58 pm

But what activity you noticed on task manager? If I was to guess then something is blocking execution of the exe file or other ones that are linked to it. Don't install any more updates, I don't think it will help here. But maybe you could enable services you disabled and then check what will happen.

Post Reply

Who is online

Users browsing this forum: Google Adsense [Bot] and 6 guests