Search found 5740 matches

by phil
Mon Apr 22, 2019 5:25 pm
Forum: XMouse Button Control
Topic: 4th (Forward) and 5th (Back) button issues with Windows Explorer
Replies: 16
Views: 1308

Re: 4th (Forward) and 5th (Back) button issues with Windows Explorer

OK I think I found the difference between the working and not working. It is an odd one, that for whatever reason, if I send the VK_BROWSER_BACK browser back key to the keyboard buffer, it causes vivaldi to go back twice. If I just post a WM_APPCOMMAND message to the browser window, it goes back onc...
by phil
Sun Apr 21, 2019 11:01 pm
Forum: General Chat
Topic: Donation problem
Replies: 5
Views: 2823

Re: Donation problem

Oh no, not at all I’m happy to accept anything donated but our latest charity event (where money goes to good causes not just mice, web servers and beer) ended and we did really well - hence the congrats and thanks! :)
by phil
Sat Apr 20, 2019 10:32 am
Forum: General Chat
Topic: Donation problem
Replies: 5
Views: 2823

Re: Donation problem

Hi Dolmatov, I'm not sure what you are getting at... The charity fund raising page is no longer linked and was completely separate from the paypal and bitcoin donations. Or are you saying the bitcoin button does not work? In which case I'm not sure why you quoted the bit about the charity fund raisi...
by phil
Fri Apr 19, 2019 8:05 pm
Forum: XMouse Button Control
Topic: 4th (Forward) and 5th (Back) button issues with Windows Explorer
Replies: 16
Views: 1308

Re: 4th (Forward) and 5th (Back) button issues with Windows Explorer

OK thats interesting, it looks like it is sending once when the button is pressed and again when it is released. That should be plenty to point me in the right direction. I'm away for Easter but when I get back (Monday probably) I'll see if I can spot the stupid error in the code that causes that :).
by phil
Thu Apr 18, 2019 1:04 pm
Forum: XMouse Button Control
Topic: Where is hwinterface.sys for controling LPT?
Replies: 1
Views: 265

Re: Where is hwinterface.sys for controling LPT?

What per say has this got to do with XMouse Button Control? did you not read the posting rules? Next time, please post to the correct forum. .... My port of InpOut32 does not use HWInterface.sys it uses InpOut.sys/InpOutx64.sys and these are embedded inside the DLL. I suspect you are either using an...
by phil
Thu Apr 18, 2019 1:04 pm
Forum: XMouse Button Control
Topic: Command question!
Replies: 3
Views: 370

Re: Command question!

Urm, you can set a timer up on the layer you switch to so it switches back after a time. That will happen every time you switch to that layer.. I'm not sure if that answers your question, I guess its indefinably. NOTE: To switch layers using simulated keystrokes you can use {LAYER:x} if you do that ...
by phil
Thu Apr 18, 2019 6:48 am
Forum: XMouse Button Control
Topic: Sometimes a button press does X-Mouse function AND original function
Replies: 3
Views: 332

Re: Sometimes a button press does X-Mouse function AND original function

Sorry, I forgot to mention that debugging turns itself off when XMBC restarts. Debugging is quite CPU/Disk intensive due to the volume of log generated and it can lag the mouse when its on so it automatically turns it off. Normally this is not a problem because its quick and easy to reproduce most b...
by phil
Wed Apr 17, 2019 8:54 am
Forum: XMouse Button Control
Topic: Sometimes a button press does X-Mouse function AND original function
Replies: 3
Views: 332

Re: Sometimes a button press does X-Mouse function AND original function

Can you please turn on debug logging, and then repeat the problem - then send me a copy of the log. Turn on debug logging in XMBC using settings -> updates and logging. Turn it on, then press OK and APPLY on the main screen. There are several things it could be, a bug, a hook timeout (especially if ...
by phil
Tue Apr 16, 2019 1:06 am
Forum: XMouse Button Control
Topic: Problem with "Media play/pause"
Replies: 6
Views: 477

Re: Problem with "Media play/pause"

OK, Got the log... You may be right, its difficult to tell without knowing when you pressed the buttons.. It does look like at 11:41:24 you pressed the 4th/5th button when chrome was that active profile (I don't know if at this time the XMBC window was open) but the media keys were sent OK. Ideally,...
by phil
Mon Apr 15, 2019 10:23 pm
Forum: XMouse Button Control
Topic: Problem with "Media play/pause"
Replies: 6
Views: 477

Re: Problem with "Media play/pause"

I have foobar 2000 here - let me try that first. But to get the log you will need to install 2.18.6, turn on logging as described above... recreate the problem (once logging is enabled) then send me the log file, either by PM or email (phil [@t] highrez [.] co [d0t] uk). Then I can see whats going o...
by phil
Mon Apr 15, 2019 9:23 am
Forum: XMouse Button Control
Topic: Problem with "Media play/pause"
Replies: 6
Views: 477

Re: Problem with "Media play/pause"

Well that's odd, its working fine here... (I'm currently using Winamp). So I'm going to need a little more to go on. 1. What media player are you using? 2. Can you turn on debug logging in XMBC (settings->logging & updates tab -> OK and APPLY) - and then invoke the play/pause actions? Then send me a...
by phil
Mon Apr 15, 2019 8:05 am
Forum: InpOut32 (x64)
Topic: Calculating In and Out percentage for multi interface.
Replies: 7
Views: 531

Re: Calculating In and Out percentage for multi interface.

Sorry, your still not giving enough detail.
What EXACTLY has it got to so with InpOut32?
What are you actually using InpOut32 to do?
What ports are you reading/writing?

I really don't see a connection nor how I can possibly help in any way?!
by phil
Mon Apr 15, 2019 8:02 am
Forum: XMouse Button Control
Topic: Problem with "Media play/pause"
Replies: 6
Views: 477

Re: Problem with "Media play/pause"

Oh dear.. I will look at that tonight. thanks for letting me know. I use these commands occasionally - normally at work so I will probably notice today if its broken here too.

2.18.5: https://www.highrez.co.uk/scripts/downl ... on=2180500
by phil
Sun Apr 14, 2019 6:41 pm
Forum: XMouse Button Control
Topic: XMBC 2.18 Released
Replies: 4
Views: 1084

Re: XMBC 2.18 Released

I released 2.18.6 a little earlier today that fixes a few more bugs reported in 2.18. Hopefully that will close out 2.18 and I can start looking at 2.19 - we shall see. As a side note; I also want to thank everyone who donated to our 2018 charity fund raising campaign for Epilepsy Research UK. With ...
by phil
Sun Apr 14, 2019 12:38 pm
Forum: XMouse Button Control
Topic: Please help translation XMBC to your language?
Replies: 540
Views: 227246

Re: Please help translation XMBC to your language?

I'm just about to push out 2.18.6 - another couple of minor fixes. This one does have a new setting - but its ONLY visible on Windows 7 and earlier as its related to the XMBC Volume/Brightness OSD which is not needed in 8.1 and later. This is due to a "bug" where the OSD did not respond to the scrol...