Search found 11 matches

by PaulT
Wed Mar 09, 2016 10:49 pm
Forum: InpOut32 (x64)
Topic: InpOutx64 with PCI-ex card (address too high?)
Replies: 4
Views: 11783

Re: InpOutx64 with PCI-ex card (address too high?)

Thanks Phil. I'll try those Ulong functions tomorrow.
by PaulT
Wed Mar 09, 2016 10:32 pm
Forum: InpOut32 (x64)
Topic: InpOutx64 with PCI-ex card (address too high?)
Replies: 4
Views: 11783

Re: InpOutx64 with PCI-ex card (address too high?)

Thanks for the super fast reply Phil. Sounds like I will have big problems getting my card to work. I've been reading through the "INPOUT32/X64 Works with SOME PCI cards" thread and some of that seems relevant to what I'm trying to do: postby phil » Fri Aug 03, 2012 8:12 pm I've just had confirmati...
by PaulT
Wed Mar 09, 2016 9:46 pm
Forum: InpOut32 (x64)
Topic: InpOutx64 with PCI-ex card (address too high?)
Replies: 4
Views: 11783

InpOutx64 with PCI-ex card (address too high?)

I have used InpOutx64 in the past with great success on built-in parallel ports. Now I have a new PC with no parallel port and I would like to get it working with a PCI-ex card. I have a card with a MOSCHIP 9901 chip which is showing in device manager (I'm running Windows 7 64-bit BTW) at address ra...
by PaulT
Sun Mar 13, 2011 4:02 pm
Forum: InpOut32 (x64)
Topic: Windows 7 64-bit problems
Replies: 7
Views: 17856

Re: Windows 7 64-bit problems

All understood. Thanks again.

Now I'm ready for the fun part - attempting to interface a modern PC to some 1984 technology :D
by PaulT
Sat Mar 12, 2011 11:44 pm
Forum: InpOut32 (x64)
Topic: Windows 7 64-bit problems
Replies: 7
Views: 17856

Re: Windows 7 64-bit problems

I think I got it working! Searched for InstallDriver.exe amongst all the downloaded files and ran it, it said "driver installed" or words to that effect, and now I can turn my LED on and off and the Beeper is working!

Many, many thanks for your help.

Paul.
by PaulT
Sat Mar 12, 2011 11:41 pm
Forum: InpOut32 (x64)
Topic: Windows 7 64-bit problems
Replies: 7
Views: 17856

Re: Windows 7 64-bit problems

inpoutx64.dll is version 1.50. I don't seem to have a inpoutx64.sys file - should I have one? I've tried so many things in the past few days I can't remember if I used InstallDriver.exe - can you tell me where to find it and how to use it?

Many thanks,

Paul.
by PaulT
Sat Mar 12, 2011 1:07 pm
Forum: InpOut32 (x64)
Topic: Windows 7 64-bit problems
Replies: 7
Views: 17856

Windows 7 64-bit problems

I can't get inpoutx64 to work on Windows 7 64-bit. The 32-bit version works fine on my wife's 32-bit XP machine so I know my test hardware is working correctly. I have it working in VB6 and VB.Net. When I say it "doesn't work" I mean that I get no output from the data bits on my test hardware. There...
by PaulT
Thu Mar 10, 2011 10:53 pm
Forum: InpOut32 (x64)
Topic: Inpoutx64 and VB.Net 2010
Replies: 8
Views: 13047

Re: Inpoutx64 and VB.Net 2010

Thanks Phil. I will work on it some more over the weekend.
by PaulT
Thu Mar 10, 2011 10:42 pm
Forum: InpOut32 (x64)
Topic: Inpoutx64 and VB.Net 2010
Replies: 8
Views: 13047

Re: Inpoutx64 and VB.Net 2010

Thanks Phil. I downloaded your example and after changing the m_bX64 boolean to "true" it runs with no errors but does not seem to write anything to the port. I am checking with a multimeter and I'm 99% sure I have the correct pins ;-) I'm not missing anything silly am I? Print spooler service doesn...
by PaulT
Thu Mar 10, 2011 10:20 pm
Forum: InpOut32 (x64)
Topic: Inpoutx64 and VB.Net 2010
Replies: 8
Views: 13047

Re: Inpoutx64 and VB.Net 2010

Thanks Phil. That was quick. I'll go check that now.

Can you also point me to "The .NET samples on my website".

Many thanks,

Paul.
by PaulT
Thu Mar 10, 2011 9:55 pm
Forum: InpOut32 (x64)
Topic: Inpoutx64 and VB.Net 2010
Replies: 8
Views: 13047

Inpoutx64 and VB.Net 2010

I am trying to access my parallel port (genuine on-board LPT1 at &H378) using Inpoutx64 with VB.Net 2010 on a Windows 7, 64-bit PC. I am getting the following error when I attempt to output data to the port: "An attempt was made to load a program with an incorrect format. (Exception from HRESULT: 0x...